The game is crashed!

Build: 38862
Platform: Steam
Operating System: Windows 10

The game crashes for no good reason! Especially often at high speed! The computer’s performance is much higher than recommended!!! Why are there no updates for six months?!

DxDiag.txt (181.5 KB)

PS for the second age updates are released monthly, for the third at the moment weekly, and for the first - every six months… why such an injustice? I understand that the first age is not so popular, but there are still players in it! Dear developers, what kind of disrespect to the fans of the first part?!

2 Likes

I had the same problem after last week’s update and at the same time got the windows update fall edition. One of them corrupted the files. I was able to verify with Steam and it seemed to have fixed it for now.

I completely reinstalled the game and nothing changed(

Have you got a dump file? Or better yet, look here at the last startup and log file and see where it goes wrong.

C:\Users\username\Games\Age of Empires DE\Logs

I just played, made it so that the game crashed (crashed after 4 min 30 sec) and the log simply did not create.

It NEVER crashed before this update (38862) (I play after 34483). Crashed mainly on speed 2.0 and sometimes 1.5. 1.0 is not left never.

1 Like

I’m more concerned with the question: why hasn’t this been fixed in four months? This error has already been reported, including me.

1 Like

I know it is crazy, but we are just flies they keep swatting away. I’ve been trying to help Decius on the Rise of Rome campaign. None of the original 1998 files will load and accroding to the debugger it’s because of access violations. So I looked a little closer and noticed vulkandriver seems to be the issue. I know this causes a problem for some players on Steam, you might want to try what is suggested in this post. I know it’s for WIN 8.1 but it might work for you.

It didn’t help at all.
PS Age crashed in 3 minutes(

Do you have the overlay active? If not try disabling or try playing offline from Steam and see what happens. We had a problem when Anno 1800 first came out and disabling the overlay fixed it from crashing.

1 Like

Also saw where uninstalling steam and reinstalling fixed the issue.

1 Like

Yes! It didn’t crash when offline, but I did reinstall steam, and it hasn’t crashed yet! Thanks, buddy)

1 Like

I’m glad it worked. I had it doubly bad when Anno 1800 first came out because I was one of the ones that got it on Steam before Ubisoft pulled the plug, so I had to have both Uplay and Steam running. I had to play offline on both for a while. Then when that got fixed anytime either overlay did some notification like a friend coming on down I went. I still can’t play with the Steam overlay on.

1 Like

Hi everyone, I think I’ve found one cause of the problem problem. My teammate and I had 4 crashes yesterday and today. We realised that it always happened when we were looking at the tech tree while in the match queue. So we tried now not opening the tech tree while in the match queue and we haven’t had a crash since.

2 Likes