The game WAS working fine now its stuck at 3-4FPS all the time --->>FIXED

Game Version:

  • Build (####) - latest one. Noticed issue 22/11/29
  • Platform - Steam

I have MSI GE63 Raider RBG 8RE gaming laptop, 16 gb ram.


The game is suddenly stuck at 3-5fps in both campaiugns, skirmish, learn to play anything.
It was working well wbut with some drops and all the other issues from launch.

Used to have 1200ish on the benchmark test, now its like 300s. The game used to jump between 30fps-60fps, other times drop to 20fps. But still enjoyed playing it and run well.

Literally palyed 18hours of this and suddenly Its not even playable anymore…

Reproduction Steps:

I don’t know?? It started happening after installing and trying out UHD - which was as unplayable in campaigns as the game is now. In skirmish would work oddly was worse at start but then it became stable and worked well enough to enjoy. Didnt bother reaching reaching castle age but it run failry well, then haven’t played the game for a few days and tried to pplay campaigns without UHD and thats when I noticed the game is uplayable.

I have Disabled, Uninsytalled and removed UHD from steam library.
Lowered Settings like fog, particles etc only to see very minimal improvement.
Lowered resolution (which makes it horribly pixelated AND doesnt even work as dragging selection box is very innacurare to where I actually click with mouse)
Shutdown and restarted computer
Uninstalled and reinstalled Age 2 DE
Checked laptiop for viruses just incase and cleanedup junk.
Tried other games and they run the same as always.

I don’t understand how this game can just get so much WORSE?? is it from the updates that were meant to INCREASE perfomance??

Someone else replied with the same problem on twitter when I complained to the Age twitter about this issue.

Screenshot from final Kotyan Khan Campaign , in a William Wallace one it wouldnt even reach 4fps in the first minute or so.

Skirmish no matter how many Ai’s its essentially the same very low framerate

if it dropped all the way down to 5 fps than i’m almost sure that it switched to using your integrated graphics card instead of the main one.
Go to program settings in your graphics card control panel to check.


thats wierd. Must have switched while playing with UHD if thats the case. This is super stupid.

Attached is my DXDiag now too. DxDiag.txt (123.7 KB)

I dunno how to do that though…
I got this error when I found something in control panel.

edit: found in these settings, set it for high perfomance but default is the same Nvidia

If you’re using an external monitor then it might be plugged in the wrong port, remove the monitor then check your FPS and see if you can open the control panel.
you can open it from the desktop (right click on an empty space then click on Nvidia control panel).

1 Like

Thanks for help. Nah I just the laptop screen it came with…

I managed to fix it just now but only since you pointed me in the right direction!! The Intel graphics driver apparently had error 43 so was disabled. Would always get stuck at updating so I clicked the ‘roll back version’ button and now game runs fine again.

I blame the last windows 10 update for this.