The resolution of the game is not good and the colors of the game are also very bad

Why is there no zoom mode X3 X2 X4 the game is very small it’s hard to see what’s going on especially I’m color blind it’s hard to understand what’s going on and the colors aren’t good either I’ve checked other games another screen everything works fine only this game age of empires 2 is problematic please do something

Have you checked your games settings ?
Make sure they fit your monitor ( Usually 1920x1080 )

I play all the games 3440 x 1440 only in this game it doesn’t work properly

I´m sorry that the game doesnt work for you like it should.
Could you try to use a lower resolution instead, so it zooms in closer ?

The quality of the game drops a lot and then you can’t see well everything is blurry

Do you use the 4K graphics add-on?

Are you using the Enhanced Graphics Pack? It is a free DLC that you can download for a 4K graphics
It may slow down the performance

1 Like

I am currently using 2K

Try to use this :
Screenshot 2023-06-01 183329

Ok I’ll check it out. Thanks for the help it’s not obvious

It didn’t work for me it’s the same

Disable all affects like bloom.

Make sharpness to 100%

Put zoom at 50%

And get a 1920 x 1080 monitor

The crispest verison is 50% zoom always.

BUT DO NOT USE 3440 x 1440.

On that monitor the 50% zoom aka the crisp clear zoom is zoomed out so your units are smaller. The 50% zoom on 3440 is like the 100% zoomed out on 1920

I literally sold my 3440 monitor because aoe2 didnt look right on it


After installing the graphics pack, you need to go into Options → Graphics, Turn “Enhanced Graphics (UHD)" on.

If you have vision problems, try disabling most postprocessing settings first. The majority of them are nothing but harmful to the game. The only one you probably want to enable is “Sharpen”.


What you call “crisp clear” is due to how the DE rendering engine works - at the so-called “50% zoom” (and when the camera is not moving), sprites appear in their native bitmap forms (before the renderer applies postprocessing effects like bloom & sharpening). At other zoom levels (or whenever the camera moves), sprites appear as mipmaps - calculated lower-detail forms of themselves.

Also, let the OP tweak the options and decide how they want their game to look themselves. Don’t forget that they are colorblind.

(And too bad AoE2DE still hasn’t replaced its fixed colorblind options with customizable player colors.)


There are several colour blind modes – click on the cog icon on the top right of the menu screen → options → interface. There’s a menu to select colour blind modes on the left-hand side.

Hope that helps!

1 Like

Could you elaborate? Where did you get this info?

Why are the heroes so blurry…

Because all other RoR units are also blurry.