The Sultans Ascend contents is still locked after buying

I received this dlc as a gift. Therefore, I cannot refund and buy it again.
I did everything recommended online. Reinstalled, restart, etc…

So I concluded this is definitely a server-side or online check problem. I remember discussing with a friend and being told that the game has an online check to see if the account has the DLC. Like a double-check system.
I tried family-share the game to my alt account, and the DLC works on that account. So I concluded that the game has another step to check the ownership of the DLC in-game binding to an account, and my game doesn’t detect that. My guess is that the UPDATE PATCH detects whether the DLC is owned or not ONCE and then locks my account’s content accordingly.
That or something was preventing my main account from accessing the DLC.
At least I can play the DLC on my alt. That’s a good thing I guess.

Thank you for the report. We are investigating an issue that after acquiring The Sultans Ascend expansion, the expansion’s content is not unlocked in-game.

It sounds like you’ve already tried some of these, but could you please try the troubleshooting steps on our FAQ: Trouble downloading an Age IV DLC – Age of Empires Support

If you still see the DLC locked after following the steps above, please reach out to our Customer Support team, it will help us collect needed information to further investigate the root cause of this problem.