Too much units with AI pathing causes lag

:arrow_forward: GAME INFORMATION

  • Build: 101.101.40220.0 latest build
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: thieftdp

:arrow_forward: COMPUTER SPECs

GTX 1080, 9900K 8 core CPU, running on NVMe SSD 970 Pro at 900p resolution

:arrow_forward: ISSUE

Too much units with AP pathing causes lag, fix this and it will fix a chunk of lagging issue with multiplayer. (this isn’t only with latest build, we had originally tested this back in May as well, just haven’t reported, this new recording is with latest build and problem still persist)

:arrow_forward: REPRODUCTION STEPS

Here’s how to reproduce the issue:

  1. Host a multiplayer game
  2. have 1 vs. 1 with a friend
  3. both sides create 200 units, all fight at same time
  4. watch it lag and start to lag less as units start to die.

:arrow_forward: Things we tried

first recording.

  • Kipchak vs Champions, it starts to lag when engaging. we thought its because kipchak too many arrows but we tried others too. (which in itself also a problem, should not lag at all).

  • Champions vs. Champions, continue to lag upon clash so we determined its most likely AI pathing causing this. AI try to find places where it can go and all the units do so at same time cause lag, this also explains why walling on blackforest playing against AI creates massive lag

2nd recording (havent upload it yet)

  • we test attack move and patrol with both aggressive and defensive stance, lag will happen. however if we use stand ground formation and patrol, there are no lag.

this suggests individual unit when patrol in a straight line, it has no lag. when there are path it tries to get to an enemy and can’t, and a lot of those at the same time will create massive lag.

:arrow_forward: GAME FILES

recording of the game:

3 Likes

Hello! Can you please provide a copy of your dxdiag to be passed along to the team? We are unable to reproduce this issue as of the end of October, but want to give it a proper look if it is still an issue.

Thank you!

1 Like

DxDiag1.txt (111.4 KB)

hope they are able to find the cause.

1 Like

an update, @GMEvangelos looks like this issue is more to do with online server. in single player scenario test this doesn’t happen, I double the unit count to 400 vs 400 to duplicate two player patrol of 200 vs 200 and it does not lag at all.

this suggest the online server has issue when handling many units, to make it worse AI pathing when patrol/attack will create more of these lags. a test play of 1v1 through online lobby (not LAN or single player) will recreate this bug very easily.

1 Like

@GMEvangelos sorry for the bump, with latest DLC patch it still having problem.

to reproduce this issue, MUST involve 2 players on multiplayer lobby, single player do not have this problem as long as your computer is good.

heres a video show case defensive stance + patrol lag which is pathing issue, 2nd is no attack stance + patrol no lag.

1 Like

This is all fantastic information; thank you for including your notes and the video. I’ve passed this along to the Test team for review, and will let you know if there are any additional details you can provide that will help them understand what you’re seeing.

Thanks again!

2 Likes

actually this problem occurs in the extremely huge map scale too.

1 Like