Town Center leaves its group when construction finishes


It seems that a Town Center under construction counts as a different object and a different type of object than the finished Town Center that it turns into when it is done. This causes two bugs that seem to be unique to Town Centers.

  1. If you add a TC to a group while it is under construction, it will leave the group after it is finished being built. (I would expect it to stay in the group on completion, like a stable does.)
  2. Double-clicking a TC under construction will select all TCs under construction on your screen, but it will not select any finished town centers on your screen. (I would expect all the town centers on the screen to be selected, the same way it works for other buildings like stables.)

The first bug in my list is the most annoying because I want to group all my town centers together so I can quickly produce villagers from them.

Reproduction Steps:

  1. Start a Standard Game with Starting Age set to Castle Age and Resources set to Ultra High.
  2. Start building two Town Centers next to your starting Town Center.
  3. Double-click on a TC under construction. I’d expect all TCs on the screen to be selected, but actually only the ones under construction get selected. (Bug #2)
  4. Add all three town centers to group #5 before the new ones are finished being built.
  5. When the new ones are done being built, press 5 to see which units are in the group, and observe that the newly-created town centers are not in the group any more, even though they were in the group while they were being created. (Bug #1)

Game Version:

  • Build 101.101.34793.0 4597979
  • Platform: Steam

Workaround for bug #2

Reassign your hotkeys so that “5” is the hotkey for “Select All Town Centers” instead of “Select Group #5”.

Please reply, Microsoft

It took me about 25 minutes to write this bug report. Please take a few minutes to give me some kind of response so I know that my time was well-spent, or else I will be discouraged from reporting future bugs.


Reported this long time ago (this was a known issue in the beta), still no fix cos they prolly have other priorities, thank you for taking the time of reporting it :heart_eyes:


This bug used to affect me as well, since I used to put all my town centers into a specific control group. However, like you stated as a workaround, I changed this habit to use the “select all town centers” hotkey instead. This actually works even better for all purposes that I used the control group for before, since it does not require to create a control group in the first place, does not take up a control group slot (if assigned to a different hotkey), and automatically includes all further town centers that you might build later and forget to add to the control group. So, at least for me, that is actually the better solution instead of a workaround.

(Of course, it would still be nice if that bug was fixed.)


Came to report this, but it seems it’s already been reported. The issue is still present, 5 months later.

1 Like

Too bad. I changed my “H” hotkey so it just selects all Town Centers, so now I don’t have to put them in a control group.

Yeah, I also switched to using the “select all TCs” hotkey, but it is not always viable. There could be a situation where you are spread out on the map, and a site gets raided, you fend it off, but have to repopulate it. In that case, it is both inefficient to accidentally make villagers from other TCs, as well as having to select the group you need manually.

Admittedly, I don’t remember being in the situation with TCs, but with military, I do. In fact, the last time was yesterday.

Besides, this is just inconsistent and it bothers me.

After today’s 40220 update ,this bug’s still there.
But official claim that this month’s update is focused on the stability and playability of the game.
If we want to do a routine booming ,assign TC to group in advance,and focus on fighting,queue villager at same time
In the end,found out that new TC idle for a long time…
We cant even double click to choose all visible TC.

This bug remind me old bug that Castle huskarl was different type to Barracks Huskarl.
Honestly,its should be fix 20 years ago…
Please fix TC type as other buildings ASAP.

When we place military buildings, like stables, we can add them to our hotkey groups, and they can start recruiting units when they are ready.

I wonder why do TC’s reset out of all groups when their construction is finished. Is it a bug?


Select all military buildings hotkeys dont work properly sometimes (every time?) in this manner too.

1 Like

I don’t think it’s about the select all buildings hotkey but rather about the inability to add unfinished buildings to a control group, even if you do it manually. Military buildings work fine for me in this regard (although I remember having problems with grouping up unfinished castles) but for tcs it indeed doesn’t work. No idea if it’s a bug but I’d also welcome fixing that.


I once read it has to do with the fact that certain parts of a TC are walkable and others are not (same with gates). If you click a Barracks foundation, it will become a Barracks once the construction is finished. But if you do the same with a TC, it will deselect. So it seems like a TC foundation and a constructed TC are seen as different buildings.


Thanks for the replies guys.

The theory about the different buildings is very interesting. Perhaps the devs could make a small patch to fix the internal transition, so that groups get updated with the new building :slight_smile:


This is finally fixed! It was fixed in Update 42848 on 2020-11-17:

  • Town Center and Gate foundations are no longer removed from their assigned control groups once the buildings are fully-constructed.

Developers: if you’re reading this thread, thank you!

I am really touched by today’s update.
But i just found that half issue still there…

Once we double click tc & select all tc hotkey to select all tc.
It’s still not allow to select all tc.
btw gate issue is fully fixed. Thank you

1 Like

And more, when u select both a TC and a TC being built the gather point can no longer be placed into resources (like military gather points act so to say). Does anyone care at this point?

1 Like