Transport ship cannot properly unload bombard cannons

I was playing a 4v4 match on a river map as Rus, opponents built a wonder, so I tried to sneak through the river a group of light cavalry and bombard cannons with transport ships.

However, the light cavalry successfully unloaded, but the cannons JUST WOULDN’T, I tried many times but they are stuck in the ship forever.

I was forced to ferry a couple of villagers instead to build a siege workshop on the other side of the river and build cannons again from scratch. While the wonder countdown is already at <5 minutes, I had to waste 3 extra minutes because of this. That was one big emotional rollercoaster, almost caused me to lose the game.

I think the problem might be due to the terrain of the coast (it couldn’t be a feature, could it?). My game is Chinese version, the map name is 汇流处, not sure what the English name is, probably “Confluence” or “River Junction”.

1 Like

Had same problem (even with the wonder). I think its related to the part that siege has bigger hitbox and rivers have there small stones or whatever so it can fit there.

Hey @VoyagerVI and @DentingOrchid7! Do you know if you click on the Bombard icon if you are able to unload that way? I’m trying to establish if this is a UI issue or a pathing issue or something else.


Hi Savage, glad to see someone from the devs are taking notice of the problems.

Actually, I didn’t even now you are supposed to be able to unload a specific type of units by selecting the icon before seeing your comment, I must have already tried that the first time and failed.

I just opened the game and tried again on the Confluence map, if I click on Bombard icon, my cursor becomes a pointing finger with a forbidden sign, no matter where I move it. This time I tried with other siege units, trebuchets also have the same problem. But smaller siege units like the ballista cart(sorry I forget the English name) and Nest of Bees can get off the ship successfully.

I then tried again on another map with a center lake, and this time there is no problem, all sieges can get off the ship. However, when selecting larger siege units icon on the ship, the cursor is still forbidden, despite I can unload them the regular way this time. It’s definitely a pathing issue or map issue.

But speaking of UI problems, I have another very big concern: when selecting garrisoned building or ships, the UI is always switched from “stats interface” to the “multiple selection interface”, no matter enemy or friendly, and there seem to be no way to switch it back? This could be a serious problem because I often use a strategy of massing ~50 spearmen to rush the enemy TC at 10 minutes. This strategy is very risky, sometimes I just had a few spearmen fewer like 45 and it would fail, the TC would end up having a tiny bit HP left when my spearmen all die. So knowing the exact stats of TC is very important in such circumstances.

Hope you guys can identify and fix the bugs and problems soon. As a part time indie game dev I understand how annoying it must be to know a bug exist but don’t know where it stems from. Good luck finding them out!

To my knowledge this is working as designed, but this isn’t the first time we’ve heard this feedback and I will add your feedback in as well.

Regarding the issue at hand—I was able to repro what I’m going to call the “Knight finger” problem, but not the “unable to unload” issue. If the transport ship itself is sitting an area where it can’t unload, and a unit is selected within it, the cursor becomes the Knight finger, rather than the ungarrison icon…so you can’t say “ok, I get that you can’t unload here, but do go over here and unload this specific unit, k, thanks.” However, if you specifically click the ungarrison button, it is then allowed.

It definitely could just be an instance of not enough space…any chance you can get a screencap of where you see this happen?

Hey, I can´t tell so since I thought it’s a hitbox problem I went to test it because it should be easy to make the same conditions.

So, it’s not a UI issue for sure. As French, I’ve loaded each unit they have (to my surprise I couldn’t load sheep) and tried to unload them all and that didn’t work.
One by one I could get all units except Trebuchet, Cannon, Mangonel. While I was doing that I’ve noticed that
to unload a specific type of unit you have to get the ship to the coast all by yourself. You cant click at unit press F and click where you want to unload it - that action is not possible until you maneuver your ship at the coast. (For unloading all if there isn’t Trebuchet, Cannon, Mangonel works fine). And if I even unload one monk, the transport ship will bounce off the coast back to the river so if you want to unload another specific unit you have to again get your ship to the coast by yourself and then do action.

Well, and the problem is by opinion somewhere with hitbox of big units, transport ship and transition of ground and water since I saw this problem only at rivers maps. Right now I’ve tested it at Confluence, Mongolian Heights and there is this problem I could only un/load big siege units at a crossing. I didn’t find this problem at Danube River, I couldn’t unload there just near the bridge.

While I was writing above and testing it I´ve also tried it with elephants they have the same problem. And I found out that I can actually load units with a big hitbox but only a few at once because I have to get them close to transport ship and click to load when their hitbox is touching. After it, they can be kinda manually loaded.
And if the transport ship isn’t in a position where it can immediately unload and you select one type of unit then you won’t get an icon that you can unload them even at positions you can.

Well, like I said before, the problem is with unloading large siege units(trebuchet, bombard) on the map Confluence. Smaller units can unload just fine, and on some other maps with waters there is no such problem. But on Confluence, this problem is very real, it cannot be simply because of insufficient space, because the ship can’t even unload the bombards at the same spot where it loaded them. Once they’re loaded, they’re stuck in the ship forever, no matter where on the shore you try to land it. I tried the entire river.

DentingOrchid7 said it even better, providing more information than I did. But here is a screencap of the map location where I can consistently reproduce the problem:

Thanks @DentingOrchid7 and @VoyagerVI! I get what you’re saying. I was able to find a quick repro. Appreciate you sticking with it!

1 Like

Yeah seems to happen specifically on the map Confluence. Was able to reliably replicate the bug. It affects siege untis with the ‘attack ground’ ability. They are prevented from ever unloading from a transport ship.