Troubleshooting for AoEDE Crashing on match launch

#21

I add to Process: “AoEDE” and “Age of Empires: Defintive Edition” but it stills crash to Desktop.
My laptop : i3, ram 8gb, gtx 520MX 1gb… can play game ?

#22

I can’t even find the folder “Window Apps”.

#23

Do you have a hard copy of the game or a digital version??? Cause I have a digital of the game and I followed all the step except for this part “You should now be able to open the WindowsApps folder.” because I couldn’t find it anywhere in my laptop I’m able to start the game until I go to the actual game where I can play for at least 5-8 minutes of the game until it tells me that a firewall of some sort is stopping the actual program from continuing on and its crashed which is really frustrating… But thank you for getting back to me asap I really appreciate all the help… Thank you…

#24

Also something about a running process I think you know what I mean right…

#25

Did you enable show hidden files in folder options? There is only a digital copy of AoE:DE.

#26

Hello, 6 months later I still have this problem. I did every step and gave my profile full acces to AoEDE.exe, but still it says: “No acces given to device, path or file. Probably you don’t have the correct accessettings for this item”

When I try to select the path with my Antivirus it won’t give me acces. Somebody know what to do?

#27

You could try to launch your antivirus program as administrator and then browse for the folder.

If this doesn’t work then you could try to paste the folder path or complete file path.

You can get the folder path by staring PowerShell and paste the following command:
dir "$($(Get-AppxPackage *MSDallas*).InstallLocation)"

This is the path for the current version, but it can change in the future and you will have to do it again:
C:\Program Files\WindowsApps\Microsoft.MSDallas_1.3.19864.2_x64__8wekyb3d8bbwe

That’s why I teach you the first method too. If you need or want to exclude the file path of the executable process just append \AoEDE.exe to it.

Copy and past the result you need in the exclusion input path of your antivirus program and it should work if launched as administrator.

I hope you find this information helpful.

#28

Ty for the response.

I think that running my antivirus program as administrator won’t work since it directs my to the windows-firewall defender.

and this environment won’t let me paste the line I retrieved from powershell

Thanks though!

#29

Which antivirus program is installed on your computer?
,As there are no known problems and adjustments needed using Windows Defender as far as I know…

#30

Ziggo AntiVirus. It’s from an internetprovider.

I tried to play, but it still kicks me out after 3 minutes in game

#31

Did you try to activate DirectPlay ?

1 Like
#32

Indeed please check if DirectPlay is enabled. Regarding your antivirus program the manufacturer is F-Secure and you should be able to follow this manual to exclude. Make sure you launch your antivirus with elevated permissions by right clicking it and select run as administrator. You also may need to paste the folder path instead of browsing. I added the latest versions here for easy copy and paste.

Folder exclusion in F-Secure:

For folder exclusion use:
C:\Program Files\WindowsApps\Microsoft.MSDallas_1.3.19864.2_x64__8wekyb3d8bbwe

For file or process exclusion use:
C:\Program Files\WindowsApps\Microsoft.MSDallas_1.3.19864.2_x64__8wekyb3d8bbwe\AoEDE.exe

#33

The best troubleshooting for AOE DE is not buying it in the first place. Because of the horrible garbage they are selling. They are basically abusing our love for aoe.

#34

Folder exclusion in F-Secure: it worked. At first I didn’t understand to EXCLUDE cause that sounds like the opposite I was thinking haha

1 Like
#35

Don’t forget to adjust the path again whenever this game updates or after reinstallation of your computer or newer antivirus program version upgrades.

#37

Ye… so. It won’t work again. Tried every step but it won’t let me play. It worked for 4 days

#38

There was an issue with the multiplayer service at the time of release of build 21322. This problem has been solved so it should work again. You will need to change the excluded folder. Don’t forget to launch F-Secure as administrator (just in case and to be sure).

To get the latest build installation path launch PowerShell and type the following.
(Get-AppxPackage *MSDallas*).InstallLocation

It should return the following output for build 21322.
C:\Program Files\WindowsApps\Microsoft.MSDallas_1.3.21322.2_x64__8wekyb3d8bbwe

#39

Ty bro! you are the best

#40

I don’t understand why they have to change the folder location / name when they change the version, this makes a mess…

1 Like
#41

That is just the way Universal Windows Packaging works. You can also override permissions on the WindowApp folder to gain access, then you can exclude the basefolder and so all Windows store apps.

The culprit here is that certain antivirus applications do not follow the Microsoft recommended way of doing things they way you should do it in Windows 10 by using MS own API’s to hook into. I don’t even have to exclude the folder with my antivirus application or enable gaming mode etc.