Two players can be assigned the same color

Hi,

Any new information regarding this bug?
My friend and I often play against AI and I always end up orange no matter my choice. This only happens in online matches, in single player skirmishes I can chose my color fine.

We were thinking and could it be caused by old AOE2 Beta files? Perhaps I set my multiplayer color to orange back then. Could it be that this choice is still being used (some local file/steam file/ online file etc.) because it was never deleted properly?

1 Like

I have seen this yesterday for the first time. It was a FN game, enemy team wanted to drop bc the were thinking it was a 3 (with coop)v4 game. Gladly I convinced them that there are 4 normal players on the map…
I dont say this is gamebreaking, but also can ruin games quite hard. Dont know how bad it would be if the same colored guys are on different teams, but it sounds like a nigthmare to me…
This bugreport is half a year old… would be time a lot of time to fix it?

2 Likes

This I don’t believe is related to dx or build number or going to be viewable in the recordings unless it contains metadata from the lobbies.

On my steam account VacuousWaffle I can reproduce the bug by hosting an unranked game, and it appears before the game launches or other players join - merely chatting w/o choosing color shows that account to purple, despite the chat being prefixed as “0 VacuousWaffle”. This color is seen by other players and persists throughout rest of game. Attempts to change color in lobby update the chat prefix (1 VacuousWaffle and so forth), but my chat messages remain purple.

Note: Custom Scenario maps still override this color. Other steam accounts on exact same computer using family shares are not affected. Logging in/out between them does not fix my main steam account. So I suppose seems I’ll have to switch to an alternate account if I want to host unranked lobbies that aren’t scenarios. Others with the bug may be able to workaround for now by creating steam family share accounts, not exactly ideal though.

Anyways though, maybe the fact that the color error is visible in the unranked lobby before launch might hint the devs where the color is being incorrectly loaded or cached. Most odd to me, but I don’t know the lobby and game launch codebase. If a dev is willing to add me on steam (VacuousWaffle) I’d be willing to launch a few tests if I’m not too busy that day.

Hey there! For those of you experiencing this issue, the team could use something called your Player.nfp file. This should be found here:

  • C:\Users[username]\Games\Age of Empires 2 DE\ [Steam ID] \profile

  • You should be able to find your Steam ID by pressing View > Settings > View Account Details in Steam.

Please save that file to a file-share and we’ll get it passed along to the team! That will [hopefully] help them figure out exactly what’s going on and why it’s only impacting some players and not everyone.

Thank you!

Here’s a link to my player.nfp file: https://1drv.ms/u/s!AkWdqeMa0xLchPdv4GpIrh0vNLod2w?e=pzOAbz

1 Like

I’ve noticed the sub-title given to this issue on the list of known issues page has changed to “need to check if still exists” or something similar. :roll_eyes: yes. I can confirm that after nearly a year the issue does still exist. Every game I play via a lobby I continue to be assigned the color green no matter which color I select before the match starts. Cmon devs, can we get this bug fixed please.

1 Like

Still here, I have the problem right now while playing with my friends.

Yep, another month on and the issue still persists. This must now be one of the longest running bugs in DE (not counting bugs that persisted since hd and aoc). First reported in this thread Aug last year, however it was occurring for me a few months before this thread was started, so it’s been around for about a year and still no fix.

Same problem here. Super annoying.

I recently played a game where there were 2 reds and 2 blues 2v2. lol Super confusing because there was a red and a blue on each team. Simply switching to team colors fixed the issues temporarily. Still, fun to play around with.

1 Like

Hey GMEvangelos, could we please get an update on this issue? It has persisted for a long long time now. As you can see from this thread, myself and others have tried to be as helpful as we can to aid the devs in solving this problem, but in return we have received no further information and this issue continues to plague us. Each of us have paid for definitive edition and this issue affects the quality of our experience when playing in a lobby game with friends. I think it is fair to say we are owed an explanation for why this issue is taking so long to be fixed.

This is a fun game mode, not a bug. Seriously. Give it a shot. I am pretty sure this is intended and not a bug (joke, but it is pretty weird that such bug even is possible)

GMEvangelos no longer works as a community manager

Hey Evan, I get this bug but a little differently and 100% consistently. Whenever I host a lobby, regardless of which player number I choose I will always be Blue in game. This happens every single time I host an unranked lobby. It doesn’t matter what colour I select or if I leave it unselected. I have no issues when I join a lobby that someone else has hosted, but if I am the host I’m doomed to be blue :frowning:

1 Like

Just making sure… are you hosting any scenario? Are you using some mods?

I have had the exact same issue since the game launched. So my friends and I have been unable to literally the play the game’s multiplayer at all since release day. Sucks.

As you can see in this screenshot, none of use are the same colors that we even chose.

Hi Vinnie, you seem to have the same problem I do. It looks like sea ape always appears as player 3. You can at least get around this by having him/her always choose player 3, that way they won’t end up the same color as someone else. Not a great solution I know, but until the devs address this bug, then it’s the best we can do. Let us know if that helps :slight_smile:

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 101.101.53347.0 7314341
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.
Colours not working as intended. Players end up with same colour even though they did not choose same colour.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 25% of the time / matches I play

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Join a lobby of friends
  2. Click “I’m ready”
  3. See you’re suddenly same colour as another player even though you didn’t choose same colour

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
All the players get their own colour.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.