Unable to Join Game Error Message


Every time I try to join a multiplayer

![image0|375x500] game in Aoe 2 the Definitive Edition it won’t let me and comes up with the error message saying "Unable to join game. Connection failed. Source: AdvertismentJoinEvent Error Code: 0x00000004.

Whenever I try and and host a game I get kicked out of the lobby after a few seconds and it says “Unable to Join Game”.
Fixes I have already tried:

  • Enabling Crossplay
  • Reinstalling and updating the game
  • Disabling my firewall
  • Signing into xbox live
  • Turing my router off and leaving it for a period of time before turning back on again
  • Setting up a hotspot with my phone - to use a different network

Any suggestions?

I am having the same issues, was able to connect a couple of times then it failed. Reinstalled it let me again play a couple of games, but then started getting the same error and now reinstalling it a third time doesn’t seem to have fixed it.

1 Like

Hi - I managed to fix it. It seems to be an IP address type issue so try turning off your wireless router for long enough that the IP changes.

I took my PC to someone’s house for them to have a look at it and it started working instantly because I was on a different network and my IP address had changed.