Unable to load or play custom scenarios in multiplayer created prior to the August updates

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 101.101.53347.0 7314341

:arrow_forward: ISSUE EXPERIENCED

Whenever a custom scenario is selected in a multiplayer lobby the game runs into an unknown error and has to end the program.

The custom scenarios are able to be downloaded by all players, everyone is able to mark themselves ready, the game is able to start and transition to the loading screen. Immediately upon reaching the loading screen, all players receive an error message where Windows attempts to diagnose a problem. This common message lasts for a split second before quickly notifying the players Windows has run into a problem and must close the program.

After some experimental troubleshooting, I discovered this issue is only experienced in multiplayer lobbies when attempting to load custom scenarios created prior to any of the August updates. I have no issue loading custom scenarios created prior to the August updates in single player mode. I created a new custom scenario today and it was able to load fine in multiplayer lobbies. Randomly generated maps and modes load fine.

No one is running any mods and there is nothing intense about any of these custom scenarios, there are no triggers, cinematic sets and so on.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Create a multiplayer lobby, invite friends and choose a custom scenario created prior to the August updates / DLC updates
  2. Wait for everyone to download the scenario and mark themselves ready, start the game
  3. At the loading screen, the error message appears

:arrow_forward: EXPECTED RESULT

The game begins.

:arrow_forward: IMAGE

This isn’t a visual bug or game play error, the game simply notifies the player with an error message at the loading screen and requires the program to end. The error message is the common Windows error message.

:arrow_forward: GAME FILES (SAVE / RECORDING)


Hi @SuperNESDisney !

Thank you for informing us. We tried to reproduce your issue but it is not happening on our side with old or recent custom scenarios. Could you provide us with more information?


After some additional troubleshooting, a friend and I considered that certain variables of our custom maps might be the issue. We finally figured out that the absence of players intended to be in the scenario causes the error. The error occurs when selecting a custom scenario and closing a player slot that is intended to be present in the custom scenario.

For example, in a 7 player game, if you have 7 players placed on the map in the scenario, and you decide that you don’t want to play with player 5 and close the slot in the lobby, the game runs into an error at the loading screen. The game must expect a player to occupy the town center but that player has been closed, and spawns them anyway, leaving them in the game with buildings but unable to control them and without a player or even AI to control them. Its as if the player or AI is both in the game and not in the game, and this must freak out the program. This is a crude interpretation of what could be happening, but this is the issue none the less. We have tried multiple maps and variables and this is always the issue.

This was not an issue prior to the august updates. When we would play our custom scenarios and close out players in lobby who were placed on the map in the scenario (for whatever reason we had), the game simply loaded the scenario and began the match without any problem. The game would simply not spawn their buildings and that player would simply not be in the game. Something must have been changed in the program or code that causes this very rare, strange error. I understand that not many people could even experience this because of the highly circumstantial nature of the error.

Hello @SuperNESDisney ,

Thank you for the extra details! We’re now tracking this issue :blush:

I can confirm I have had similar issues with this, and it was an utter nightmare trying to figure out what was happening.

Recently was constantly having my game nuke itself when hosting a multiplayer game, using one or two of the custom scenarios I had created myself. Couldn’t understand why it was doing it, but eventually also came to the same conclusion as the OP. All my custom scenarios facilitate 8 Players, but it seems any time I try and host a multiplayer game, using one of these scenarios, if there are any closed slots (i.e, not 8 players), the game implodes on start. I can’t remember if it always used to do this, but I’m pretty sure in the past we could get away with leaving one or two players closed and their town centres would simply not spawn.

If this could be fixed it would be great.

Thank you very much; if you are on Steam please let us know if the issues are fixed for you in the November Public Update preview.
@stephenb19191 Scenarios should work again with some player slots unattended.

1 Like

Hello, the issues have been fixed, including many other minor issues I was experiencing. Thank you very much for your continued support and effort, it is greatly appreciated.

1 Like