Units don't move! When I gave them move commands 1 million times

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 82587
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

There are 2 archers that are stuck in open field forever. Right clicking them does nothing. Changing stance does nothing.

:arrow_forward: FREQUENCY OF ISSUE

Yes, less than 25% of the time. But this should not happen one single time!

:arrow_forward: REPRODUCTION STEPS


:arrow_forward: EXPECTED RESULT

What do you expect?

:arrow_forward: IMAGE

These 2 archers are stuck. Timestamp ~20:07

:arrow_forward: GAME FILES (SAVE / RECORDING)

MP Replay v101.102.17051.0 #(82587) @2023.05.09 202245 (1).aoe2record (1.5 MB)

You are truly marvellous devs. Biggest patch ever, of bugs.


Do you remember if you commanded these 2 units to patrol move or attack move?

1 Like

Hey I said I issued a right click move command. Would you be able to retrieve what commands I issued thru the replay file?

since the xbox patch this issue was introduced. attack move, patrol or just regular right clicking to move would result in this randomly. (randomly as in unit collision causing this).

edit: I have reported this bug with another video showing this a while back but looks like it wasn’t tracked.


Yeah, I command my units to attack move, and they just stop attacking after defeating one target. It gets straightened out once I issue the command again, but it’s a pretty major problem to have half my army not fighting while the other half (usually the weak ranged units) gets demolished.

Yes, we are tracking this issue.

1 Like

Hey I managed to get a recording of what happened. Take a look how ridiculous it is. The 2 skirms near the ranges just refuse to end their vacation.


@Felizon89 this bug is still not fixed.

my KTs got stuck yesterday, had to move them 1 by 1 to get unstuck

I just suffered from the same problem. Three knights refused to move despite giving them a move command repeatedly. Recorded game included.

MP Replay v101.102.20078.0 #(85614) @2023.06.17 211753 (1).aoe2record (3.7 MB)

22:14 → knights attack move on M@A
22:26 → knights cleared M@A, now standing still.
25:10 → knights are part of larger control group and were tasked to move somewhere; they didn’t.
25:33 → I tried to move the stuck knights; they didn’t.
25:42 → I tried to delete some houses around the knights in case they were somehow glitched inside them, even though it didn’t look that way. It didn’t work.
26:05 → Deleted the knights because they were useless.

1 Like

This bug is still not fixed. Here is an example of two stuck skirms not moving even when issued any number of commands (starting at 15:30 in the attached rec).

stuck skirms
MP Replay v101.102.28520.0 @2023.10.15 170056 (1).aoe2record (2.1 MB)

What’s more epic, TaToH lost 3 trebs vs DauT in TTL Ro12 G1, because of this bug:


I played against the AI a few days ago, and it also seemed to experience something similar. It had a bunch of crossbowmen and skirmishers standing outside my base after retreating from a defensive tower. They did not pull back to defend against my offensive tower builders. A few minutes later, my knights and scouts arrived and chopped them down without resistance at all. (Almost unethical.)