Units randomly getting stuck permanently

Game Version: Age of Empires: Definitive Edition

  • Build ((28529))


Sometimes units can get stuck in the terrain seemingly at random in a way that they’ll no longer react to commands. Here it is on video:

While the video only shows them not reacting to the right click move command it’s the same with any other command the player would issue. The only “solution” is to just press Del and make new units instead.

Reproduction Steps:

Not really sure sadly but it seems to happen after a unit engages in combat / the. player gives the attack move command.



It’s quite obvious with villagers now.
Their hitbox behaviour is inconsistent.
Sometimes they get in between trees or berries, so they cannot get out of there anymore.


Like I said before, everyone is focused around AoE 2:DE right now, be AoE:DE needs just as much work, sadly.

I don’t understand how they can simply move to the next product before the first one is actually finished.


Cause it’s really cost efficient.
That’s it.

Everyone buys it cause of a nostalgia hype (means the game itself doesn’t even have to be convincing since they just yoink the convincing underlying title (only the game it’s based upon has to be)).

High system requirements with bad performance an aweful netcode and tons of bugs paired with a really bad Store policy while binding this game to a new operating system version are all things that made AoE:DE an even more fundamentally broken “game” than it is now.
Nobody can tell me that they bought the game cause they checked out some review/gameplay and saw a convincing program/game to play activly.

Not even speaking about missing basic quality of life features like proper quickchat, proper balance, ping feature, command queues, unit behaviour in general, too big random factor with mapspawns and now even multiple clients with a steadily decreasing playerbase and yadda yadda.

Quick cash in on the good memories of the past while having not that much effort behind it.
Just use the good reputition of the old game to let yourself get hyped into heaven.
The fact that they cut music diversity or variety in animations of units is the ultimate statement of “we just want it to work and not more”.


yes. Tired of the bugs and the annoyng silly AI. This game is clearly broken. The AI in most cases is worse than the original game.

1 Like

I’d love to get a bit more info:

How often do you see this in game? (Every game, every 3rd game, once in awhile, almost never, etc.)
Do you notice it happening with specific units or is it random?
Are you on Steam or Windows?

Any other info you could give would really help out :slight_smile:

1 Like

this is a very common Problem and happens almost daily. I will give few examples.

  1. Hunting elephant used a villie to lure and the villie got stuck behind a tree. Multiple click somes time fix but it is a common Problem.

  2. Dock Rally Point - sometimes the fishing and Galley boats are stuck on the Edge of the coastline after pumping and cannot move (no matter what you do).

  3. Same issue with army Groups. One unit in Groups get stuck and blocks the whole army and have to click multiple times to fix it.

Just fyi -

Team game ELO is bugged. UI scale is bugged and lot of other issues already discussed. I hope you guys are Looking into it.


I’d say that “once in while” describes it’s frequency quite well: it’s not something that’s plaguing the game as a very frequent issue but it’s definitely noticeable and it can have an impact depending on what unit gets stuck.

As for what units it can happen to I think it’s infantry units like swordsmen or hoplites / centurions, I don’t remember seeing this with bigger units like elephants of catapults. There is a very similar issue that may be the same thing though: sometimes villagers just stop farming and they get stuck in the middle of the farm. They don’t react to commands either.

I’m playing the game on Steam.


Very common with ships spawning from docks to get stuck on the shoreline and be permanently stuck. At least one warship in every game where I mass warships, usually some more. Feels like this happens more often on river docks that sea docks but not definitive proof of that.

Villagers can phase between unwalkable objects, this happens maybe once every three games for me. They go to berries but somehow get behing the berry bush, unable to get out. Same happens with trees sometimes, but more rare since trees usually don’t leave spaces.

Rarely units just get stuck on their own and can’t move, they respond to commands by turning but can’t move. Sometimes it’s morethan onee unit and deleting some from the stack helps, sometimes it doesn’t. Happens on corners of stones, buildings, gold, very rarely trees or plain field. I have a feeling it has to do with the new turning angles not meshing well with the collision/pathfinding in DE but no proof of that. Maybe 1-to-10/15 games for me.

Also some trees-to-tree or tree-to-small wall connections are passable for units. Build a diagonal wall ip to a treeline with small wall, drag it inside the forest to be sure and there is still a hole big enough for units to pass through, even though we can’t build a wall there! Have to build another wall tile not diagonally to block fully. Very rare, 1-to-40/50 games for me.

MS store crossplay client.


Game Version:

  • Build: 38862
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: 1v4n94


Land units getting stuck.

Reproduction Steps:

I was in the middle of a battle when it happened. Apparently, having lots of units has something to do with it.


I would say there’s a high chance for this bug to occur, since I spotted it two times in just a handful of hours.


UPDATE 38862


If you move them one at a time, this is usually corrected. But yes, this is a bug(((

the patchfinding and the unit stack has been greatly improved. Thank devs. But the mass army unit getting stuck and not moving till some of them are deleted is still happening ocassionally. It happened with almost all types or army unit. Catsphracts, Ele-archers, Legions, etc.

1 Like

I agree. It happened two times in the course of a couple hours in my case. One of them being the Elephant Archers from my .gif, and the other happening with Legions.

It’s sad to hear that the issue still exists. It seems like they are patching the game on a regular basis but some old issues (like this and the stutter with higher zoom levels) are being overlooked.

1 Like


Yes, I tried. But only worked for some of the units affected, not all of them :slightly_frowning_face:

I saw this today. A Villager started walking on water like it was Jesus, just to reach a tree to chop down, which was originally obstructed by a building.

lol i like the vid title

1 Like

Hello, friend! I want to add a GIF such like this one of yours on my last bug report. How have you made this one? Thanks!

1 Like

OBS Studio first to record, and to convert the video to GIF, this tool.

1 Like