Unplayably bad feezing in all single player campaigns

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 8752729
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: Whenever I start any single player campaign the game starts freezing within 30 seconds or so. It’s most noticeable when trying to switch control groups - they just don’t switch. The game is not completely frozen, but I can’t control my units, so it is unplayable. Also when this happens, my computer makes some of those “error ding” noises that windows makes sometimes when something is going wrong.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Start any single player campaign (first Joan of Arc for example)
  2. Try to play normally
  3. Experience game breaking freezing within 30 seconds

:arrow_forward: EXPECTED RESULT

my computer is new and beefy, my score on the benchmark is 1200. I expect this game to run smoothly.

I’m aware of the virus protection issue. I only use windows defender, and have already added all the steam folders and the AOE game executable as exceptions. This did not help. I have completely reinstalled the game as well as checking my disks for errors and updating all my drivers. Nothing has helped.

I have NOT bought the India DLC but would really like to! If the game was not completely broken I would have done so already.

I originally played through several campaigns last year with no issues, so it seems like some update since then has caused the issue for me. I have an AMD Ryzen system but Nvidia graphics card.

hey @chazzycat5240

Thank you for your bug report.
Try verifying the game files, through right clicking aoe2de in steam library, properties, local files, verify integrity of game files.
If this did not fix the issue, does this only happen in single player campaigns?
A video of the issue happening would possibly help a lot as well.

Thanks for the response. I have indeed tried verifying the game files already and it did not help.

I am only interested in the single player campaigns so those are the only things I have tried. I will try a skirmish later and also try to get a video.