Using new aura effect on buildings breaks building gather points

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: Current
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


When modding something using the new aura affect (like the Caravanseari), if the affect is given as a task to a building that can train units, clicking any of the objects that would be affected by the aura becomes possible, even when it shouldn’t be. For example: If a Town Center has been given the new task, and would increase the work rate of nearby civilian units (class 4) by 10%, whenever the TC is selected, if the player clicks on a civilian unit (villagers), the green circle of the gather point being placed will appear, but the gather point won’t be set to the vil. This is extremely problematic, because it rules out a lot of the things the aura could do for modding, as it’s much harder to play when you can’t set the gather point onto food under the Town Center like you normally would, because the game treats it as clicking a shepherd, without actually changing the gather point.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Create a copy of the empires_x2.dat file in a mod, and add the new task 155 to the Town Center (ids 71, 109, 141, and 142).
  2. This task should be configured to effect class 4, work value set to 0.1, work value 2 should be 1, range is 9 (although anything should work), search wait time is 13 (increases productivity) and unused flag should be 5 (show range indicator and multiplier style effect). Leave the unit combat class as 2, because this will take effect even without generating the aura.
  3. Load the datamod and test the game. Select the Town Center and click on any villager.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

Adding the aura task doesn’t allow selection of units that shouldn’t be selectable.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.


:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

Thanks for the report, I let the team know about this issue :slight_smile:

1 Like

There are lots of bugs in aura effect (task 155).

some issues ive noted down that the centurion purposely used units, not class to buff.

when used class, a lot of stuff gets jumbled and starting having weird behavior and buffs other things that isn’t suppose to be buffed. the more you have the more it messes up. then theres also range, some with range less than 1 screws the game up and buffs outside the less than 1 range.

in the hotfix which was the PUP, this wasn’t fixed either. @Felizon89 pls have them fix this as its part of core game feature and not just for modders. buildings like celts castle, hindustanis caravanserai etc are all affected

For now,
Unused Flag must include 2(Round Area),then can affect the setting class/unit as expect.
Otherwise(not include 2, Square Area) affect all units, bug.

actually I have the opposite. I think its more to do with class vs units.

No, they’re both broken, I originally had it just affected all the specific villager variants, but that had the bug, so I tried class. Neither way works, the issue is present regardless.

No, I have gotten them to work with the units I wanted for now but it is a mixed of things with no consistency. once they fix it some things will need to be reverted but you just need to try each one until you find one thats working.

I tried both ways though, and at least in the context of what I’m doing, neither of them worked.