Very Confused: When I load into any game my POV stuck at top of map cannot play

Whenever I log in and start a new game either against AI or on multiplayer when the game starts my camera will stay at the top of the map and whenever i try to go to my TC or my idle villagers it sends me immediately back to the top of the map.

It is unplayable I had to resign after 10 seconds in a 1v1 game earlier and lost elo for something out of my control - very frustrating.

Only way of fixing is it restart my whole PC. If I just restart the game the problem remains.

Also cannot see any other thread regarding this issue but if there is please let me know.

Any help or ideas for this?

I’ve saw a few these posts before. It seems it might be an issue with some .exe / program that is running while u are playing your game. It’s possible it can be some driver for graphics or similar.

Hi TurnupLion2, welcome to the forums!

Could you provide more info on that? Game version, platform, the maps where this happen and if you could happen to upload a video of the issue it would be great.

But also make sure that this is not related to keyboard and mouse inputs. I’d suggest do disconnecting those two, one at time, to try to funnel down the issue.

Thank you for your reply - yes I was wondering if it was a program in the background which may explain why restarting the whole PC would fix it. No idea how I could realistically assess this though. I suppose not having the most up-to-date graphics driver could do it.

Hello!

Latest game version, platform is steam, the maps were Arabia and Golden Pit - I will see if the replay’s player lock works if not next time it happens I will record on my phone.

I too was wondering if it could be the inputs problem - but I have a very new keyboard and a couple month old mouse so I very much doubt this could be an issue especially as there’s no negative consequences using any other game etc. On this note, do you know if there is a hotkey/s that moves the screen other than moving your mouse cursor to the edge of the screen?

Thanks for your help!

You have to watch the replay on view lock from my perspective: ‘chuke’ and you will see what happens. https://drive.google.com/file/d/1eBcl0uuSbiqNLyFLFp8JQ9r-nQ7g_QUX/view?usp=sharing

try loading up the game, starting a match, and when the problem occurs, go alt tab into Task Manager, look at processes, and try ending them 1 by 1 and checking if that ends the scrolling to the top.

(i am pretty sure that it is not a keyboard and mouse issue, as i’ve seen this issue over the internet and it’s common, its most definitely problems with some program running in the back)

Yes, the arrow keys can also move the camera. If I were you I would give it a double check, wouldn’t hurt!

1 Like

I got a similar issue where the camera don’t go directly to the top left but instead it moves slowly to that position and the only way to solve the problems is by restarting the PC, I’m playing with the 101.101.37906.0 5105673 version.
The camera moves by itself

Hi Lucsor00, welcome to the forums!

Go check you scroll speed and inertia settings.

The bug happens from time to time, so when it happens again, and I’m sure it will, I’ll try that. In order to get it right what should I do exactly? reduce the DPI, the scroll speed or other thing? and I don’t know what are you trying to say with “inertia settings”.

These are settings, on the settings menu, that you can tweak to better fit your taste.

yeah, but it’s not about taste. it’s about the camera moving by itself, like if it has free will.

Oh so it is moving by itself? By your initial description I thought it to be a problem related to the settings I mentioned.

In that case I would recommend trying to test different bindings for the scroll keys, experimenting with unplugged and different keyboard hardware.

If the problem persists we can figure what to try next.

I’ll try to do that, and announce if it’s work or not. Unfortunatly I must wait until the bug show up again, so until then thanks for everything.

1 Like