Very few lobbies show in Lobby Browser


After the last update I have very few lobbies show in my Lobby Browser. I remember having the same issue during the beta, but seems its back. There are hundreds on so it’s just me.

Anyone else had this issue and know how to fix?


I don’t believe that this is an issue with the game.
It appears that in your settings (on the right) that you have Treaty = Yes.
This is a game mode that very few players actually play - thus the small number of games being shown for you in the lobby browser.

If you change that setting to “Any” or “No” I’m sure you will see a great many more results.

Hope this helps!

1 Like