Villager vs building targeting

This was already fixed/improved in an earlier patch, but seems to have gotten worse again with the April Patch.

There’s a lot of things like that. It worked well but then after the next patch some other aspects got improved at the same time these aspects started working incorrectly.

Not sure why is it so common for de. It almost sounds like the code is tangled, classes are overlapping and it’s really tough to find a specific part of the code that influences only one thing.

1 Like

Ya, something in this directin ois probably the reason for most bugs/weird behaviour.
After all theyre working with the original engine and 20 year old code. So yeah you can imagine…

After playing more games and analyzing the situation I noticed that damaging fortifications (towers, castles, kreposts) work correctly as I mentioned here:

as long as you don’t manually re-target the focus of the fortification building to something else.
Once you do that the tower starts shooting the closest thing (whatever it is - object/fortification/building) and will continue on shooting it until is told differently. After the targeted unit is killed or leaves the range of the tower it will once again target the closest thing until told differently.

In conclusion:
The fortification (tower) forgets how it should be working after the player gives it any command.

Best Regards
RediRodion

3 Likes

that really sucks! and thanks for sharing, was wondering why sometimes they seemd to work and othertimes not

I think the same

1 Like

That’s unrelated to this thread. The thread you linked describes a different issue, which is also reported here:

Adnotation #2
07-05-2020 | Malfunctioning Mechanics

This is still an issue.
(Towers don't automatically attack units when in firing range)
It is game braking.
It is heart braking to suffer it (reported at least since early May)
Please fix it as soon as possible.

1 Like

It really does suck. Obviously not sure if you’ve tried it. But apparently this only happens if you give the tower an order. If you completely leave it alone apparently it does what its supposed to. But if given an order even when the target dies it loses its auto target units ability…

Ive tried it in game and seems to work. But obviously this issue could still be happening to other people even without interference.

But i still get the issue where if i try to target things the towers go nuts and shoot buildings first…

1 Like

This man is saying the truth.

1 Like

Sometimes you simply have to manually retarget a tower. Imagine e.g. the enemy baiting fire with the scout/a unit. You are forced to manually retarget.
So this still defo is a very annoying issue.

2 Likes

:arrow_forward: GAME INFORMATION

  • Build: July 2020 patch, but I think this issues has been around longer
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag:

:arrow_forward: ISSUE

When a tower is not ordered to attack, it will choose a target itself. In the situation where both units and buildings are available to attack, the tower will attack the unit automatically. Whenever there are no units within reach, the tower will attack a building. The tower will now lock its fire onto that building until the building is destroyed (as you may know, this takes forever). It used to be that towers would switch its focus onto units whenever units where within the attack range, but that doesn’t happen anymore.

:arrow_forward: REPRODUCTION STEPS

In a real game scenario: build a tower on an enemy woodline. The tower will attack the vills automatically. Whenever the vills are gone the tower will attack the lumbercamp or an other building. If the vills return the tower will still attack the building.

:arrow_forward: GAME FILES

See attached.

The tower is placed around 18:40 and attacks villager. The tower is not ordered manually to attack the lumber camp. You’ll see it does so automatically when vills are outside the LOS.

Villager return around 37:30 and the tower doesn’t attack them.

How can I upload a recorded game?

:arrow_forward: IMAGE & ATTACHMENTS

It’s kind of hard to see from this image but the lumber camp HP bar lights up implicating it is the one that’s under attack.
*

6 Likes

Will I hear it if this gets logged as an official bug? This issue seriously impacts the effectiveness of offensive towers. By the way I think the same issue applies for castles and town centers but I am not completely sure.

3 Likes

Same issue?

2 Likes

Yes same issue. I am glad the DE team is aware. Hopefully they will fix it in the July patch.

2 Likes

Correct, I reposted and commented about it multiple times after multiple patches.
The latest one in here:


No fix, no response.

1 Like

DauT trushing today: “shoot the vils you stupid tower, you can range them”

Looks like this is a key part of the problem; thank you for including it here! This helped us reproduce the issue internally and get a bug passed along to the developers for review.

Thanks, everyone, for staying on top of this problem!

2 Likes

@GMEvangelos
I already said it on 6th July
MonkaS

2 Likes

Here :cookie:
Post must be