VIllagers walking inside the blueprint and idling instead of constructing

There is a bug that I keep getting since I started playing 1 month ago or so. At least 20% (probably much higher) of the times when I order a villager/many villagers to construct a building(s) they walk to the middle of the blueprint then do nothing. I have seen a similar bug reported more than 1 year ago so I don’t know what is happening. I tried to reinstall the game, still having the same issue. My friends say they don’t have it, so it feels weird that I am the only one in the world having such a bug and it happens tens of times every game.

This is very frustrating not just because of wasting my time doing things multiple times, but also there are times where I put say a town center/market whatever then minutes later I realize it was not built because I ordered my idle villagers to do something. It is even more cancerous when the villagers don’t construct the landmarks.

If needed I can provide videos showing the bug. Lastly, it happens with and without shift queuing.

Hey @ProtossAMove! It would be fantastic if you could produce a video. Are you seeing this only with a particular civ and/or building? Is this happening with only a few Villagers or when you task a whole bunch to a single building?

Hey @SavageEmpire566. Thanks for the reply.

Here are some videos, in which I created a sandbox match, notice however that the bug occurs in all kind of games multiplayer or not. Additionally the bug happens whether using 1 villager or multiple and with all kind of building sizes (including landmarks).

One more thing, at some point my friends suggested I use right click after putting the building to prevent the bug. Nevertheless the bug occurs with and without rightclicking maybe even more often with rightclicking (the bug can also happen while queuing building commands although not included in my videos, in this case there has to be a right click). The bug can also happen when adding new builders to a building being constructed they reach the building and go idle (Sorry I don’t have a recording of this right now). Lastly, I don’t remember it ever happened to me with farms for some reason.

So far I haven’t figured out how to reproduce the bug with 100% success rate, so to reproduce it I can just do buildings or do any normal game, it happens lot of times in all of my games. So I can record or share replays of my games (username) if needed.

The videos I included here are live recording, i thought this is better than recording while watching my replays.

1 Like

Thank you for the video. I just spent a good 30 minutes spamming buildings and didn’t see it one time so I’d guess there’s possibly something else at play here.

  • Do you see this only in a particular Age?
  • Do you see this only with specific buildings?
  • Do you see this only with a particular civ?
  • Are you using any mods?
  • Are you using a custom hotkeys and then using those when you see this?


In principle this happens regardless of the civ/the age or the building type (except that I never had it with farms as I mentioned earlier). I don’t use any mods. For hotkeys, I use a grid profile (so outside of the grid there are some selection hotkeys for example that I changed to fit me, but for putting buildings and such it is just grid).

I will update you if I find something new as this seems a non trivial bug to fix or to understand what is going on (+ I will observe my own (unconscious) behavior and if there is ever an issue with my keyboard e.g some keys being held down/stuck whatever)

1 Like

@SavageEmpire566 I found out something at least for the case in which I right click the building (which also happens when queuing multiple buildings in some cases) after placing it. Due to quick mouse movements, even the Slightliest duration of holding down right click makes the command a Move command with "direction choices "(like the one we can use to chose armies orientations), very often one can spot the blue line (for building command) change into yellow which I originally never noticed, this can also be seen in the vids above. I said “slightliest duration” and as you can see the blue line turned into yellow super quick. For some reason this is doable with villagers and even on top of buildings foundations, even when having the hammer icon. This seems to require less holding time if done immediately after placing a building.

Now the question is why I had this “bug” in the first place before my friends made the bad suggestion of right clicking (at the time it wasn’t as frequent as right now) which probably gave me bad unnecessary habit. I will get back to you if things go bad even while avoiding right clicks, until then I will make sure I don’t accidentally make right clicks (this habit can also be acquired from building mills and spamming farms around in which case one right clicks the mill at the end of the commands).

In any case, I think the move command shouldn’t be usable with villagers on top of foundations (and to be honest I don’t know anyone who cares about orientation of villagers :D).

I also just tried to add builders to a building being constructed it works the same way with the hold right click thing. So now I can reproduce this one as well. However in this scenario it seems to require longer Holding down which probably explains why it happens way less often.

1 Like