Weird download/install loop

I’m trying to download and install through the Xbox app for Windows 10. I hit install, it says starting > downloading > and then it throws out a notification saying AoE II : DE just got installed and to check it out. Icon is in my start menu but when I click it that takes me to the Windows store. I uninstall and try again and get the same result.

Most recent version of Win 10. Everything else on the Game Pass app works just fine so I’m at a loss here.

I’m having the same problem it gets to a 100% then fails to install, then i try to install again and it downloads it instantly then does something to a second then flashes back to Install again.

I’ve tried uninstalling, changing Hard Drives etc… all my other Gamepass games work amazing.

Same exact problem, any updates on if you guys have fixed it or not?

I formatted my SSD and it did download and install, but then I ran into problems trying to update the game so I just gave up on it. Every other gamepass game I have on it works flawlessly so I’m not sure what the problem is here.

I hope you guys have better luck than I do getting it working!