Xbox achievements not unlocking whilst playing on steam

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 100.13.18214.0
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.
I´ve recently bought the Knights of the Mediterranean DLC on Steam, however when I unlocked a number of achievements on Steam they did not carry over to Xbox live even though I was signed in.
First I thought that it might take a day for the Microsoft servers to update, but when I checked the following day they still hadn´t unlocked.
I then signed my Xbox live account out and in again and tried another game, but they still did not unlock and I cannot find a solution in the forums.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Start the game on Steam
  2. Sign into my Xbox Live account on the AOE II DE homescreen
  3. Start a game (tried both skirmish and multiplayer) and fulfill the conditions for an achievement
  4. After the game is completed no Xbox pop-up or notification appears, but the Steam notification does appear

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

The completion of achievements on Steam, whilst being signed into my Xbox Live account, should also unlock the achievements on my Xbox live profile.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe3Ysav) or GAME RECORDING (.aoe3Yrec) of the match where you encountered the issue. Link it below if using an external file service.

It still has not synchronised with the xbox network. Is there a solution?

I am having the EXACT same issue. Is there a solution yet?