Xbox Series X - Cannot delete unit when playing with mouse and keyboard

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 101.102.9814.0
  • GAME PLATFORM: Xbox Series X / Microsoft Store

:arrow_forward: ISSUE EXPERIENCED

When selecting a unit, it is not possible to delete it. The delele button is missing from HUD and the hotkey does not work either.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Start a game with mouse and keyboard control
  2. Select a unit
  3. Try to delete it

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
Killed unit

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.


Same issue here, have to use siege units to kill the things i don’t want

1 Like

Thanks for this report @icekuSWE I’ll investigate this issue.

1 Like

Please remember to add back the mouse-operable delete button to the PC version too. Deleting units shouldn’t be a keyboard-only function. The Xbox Cloud Gaming Touch mode has one.

1 Like

@icekuSWE I am still experiencing this bug using my keyboard on the XBOX Series S. Neither the key assigned to delete all selected units nor an individual unit does anything. In some circumstances, it is a game-loosing bug (no quick wall, no opening of walls in tight maps, not removing unfinished buildings to get back resources).

Are there any plans to fix this bug? Thanks in advance for your reply.

Good to see this brought up but a shame to see it ignored. I remember playing on PC in '99 with just mouse, just fine, and it is daft to see that we’ve gone backwards 24 years later. I realised how much we are lacking in the Xbox UI when I tried to play with just mouse recently, and found it to be quite the challenge.

Between this issue, the fact that the UI disappears if you just slightly misclick a unit production button, and the inability to see diplomatic status on unit information, we really are being treated like an afterthought. I don’t understand why we didn’t just get the PC UI copied across. I mean we tend to have bigger screens and higher resolutions on TV screens, so it is not as if we don’t have space!

I’ve been meaning to play through campaigns as I’ve not done any post-Conquerors, but these ongoing QoL issues are really off-putting. We’ve had the game on console for 6 months now, and it really should be more enjoyable to play.

1 Like

How are we looking for getting some UI love on the Xbox? This issue along with the disappearing unit grid are quite longstanding at this point. Cheers.

Wow! This bug is still not fixed. Whats going on? I can bind delete unit with keys I want but nothing happens when I want to delete unit. I cannot play this game like this.
PS. I am using razer tartarus v2 keyboard