Yet another can't launch forum

hello all,
I have been troubleshooting this for hourse and have finally given up on my own. I have the same problem as many, I get the splash screen and then crash to desktop.
I am running windows 10 pro x64
32 gb ram
Nvidia GTX 1080M

by all accounts I blow all of the system requirements out of the water.

fixes I have tried include:
reset AOE, windows store, and xbox live apps
install candy crush
uninstall/install candy crush/reinstall
disabling wifi
pinning and unpinning from taskbar.
set AOEDE.exe to run as admin
performed clean install of most recent graphics drivers.
enable push to install service (windows store service is not present)
enabling access to built in admin account and launching from there.
taking ownership of \programfiles\windowsapps and subfolders.
direct play feature is already enabled.

I’ve even resorted to performing a DISM and SFC scan to make sure I don’t pooch my own system too bad. any direction would be great, I am going out of my mind.

1 Like

You really did a lot, too much actually and especially taking over the ownership of the WindowsApps folder is definitely not recommended and also not advised anywhere on the forum here.

Anyway I have a few more questions before we continue troubleshooting.

Which CPU is installed in your system?

What is your current Windows version and build?

Do you use any third party antivirus software? If so which brand and the full product name.

Windows 10 version 1903 build 17134
CPU is Intel i7-6700K
I only use windows defender, and currently have smartscreen for windows store apps disabled.

Could you post a screenshot of the App-settings screen of AOE DE?

how do locate the app-settings for AOE DE?

Right click on tile, go to more and choose app-settings. Use Alt-PtrSc and paste back (Ctrl-V) into your answer here. Works like a charm.

As you can see the app has no permissions to access your account info. Something is definitely wrong with your Windows 10 install. I would recommend you to perform an in-place Windows 10 upgrade or even better to do a fresh install using USB boot media.

Actually to me it looks like you have changed some local policy setting since it’s greyed out or is this pc domain connected?

this PC is not associated with any domains. I had turned off app account access.

to troubleshoot this, I have enabled account info permissions and background apps permission, and rebooted. no change in behavior.

I’m going to assume the “M” is a typo since technically nvidia no longer designates their notebook GPUs with teh “M” moniker

However generally speaking, issues with mobility chipsets stem from the fact that the game isn’t using the Nvidia GPU. You should force the GPu to be used via the Nvidia control panel

I do not see an option to force the GPU in the nvidia control panel. I also do not have an intel HD graphics adapter or any other secondary Graphics adapter so I am not sure that would be what is causing the issue.

Was this a fresh Windows 1903 install through USB boot media or an upgrade through Windows Update?

an upgrade through windows update. however, when performing an online DISM scan, your windows directory is compared against a known good image and repairs any corrupted or missing files, and running SFC afterwards will repair any missing or corrupted DLLs. as both were run in the TS process a clean install should not be required. also, something I should have mentioned is that AOE DE did work at some point in the past with this install, albeit rather buggy and required me to skip the startup cutscenes or it would crash. it is only now after about a year later that it does not want to work.

Never mind. You should have mentioned that indeed, but still an in-place upgrade using the media creator tool could automagically solve your problem. I always use the specific build ISO and extract that to a local installation source (e.g. C:\Install\WINXUPG\1903) and use my own homebrew upgrade script.

I would advise you anyway to download the latest media creator tool and just run it and upgrade your system again. It doesn’t hurt or at least it shouldn’t and only costs some additional waiting time.

Is your computer a branded model or clone? Please list the brand and model type of your pc as well for completeness sake.

it is an Origin EON-17S, 2017 model. msinfo screenshot attached for exact model.

It has an fairly old BIOS (July 12th 2016). I tried to look up a newer version for you, but Origin PC has recently been acquired by Corsair and I can’t access their FTP driver support site at to check for a newer BIOS for your laptop. It’s heavy gear for sure and should be capable of running AOE DE fine, like it did before.

I hope you can find time to try that in-place upgrade using the media creator tool.

American megatrends does not write BIOS updates for notebook boards often. my last Origin laptop never had a single available update the entire lifespan of the device. I will try the inplace upgrade this weekend during some down time.

It all depends on the quality of the OEM that produced the mainboard and if Origin keeps track of those updates. Usually there are always at least minor BIOS updates and regarding the spectre and latest other vulnerabilities there could be major ones. Yet, it all should not affect AOE DE.

Just keep me posted here about the results.