Absence of FPS cap damaging performance and causing dangerous heating on lower-end systems

:arrow_forward: GAME INFORMATION

  • Build: 101.101.39515.0 5328560
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: Ayase_Chihaya

:arrow_forward: ISSUE

:question: Describe the problem in detail (below). Please limit to one issue per thread.

In early stages my game is running mostly in the range 60-90fps, which causes my system (a low-end laptop) to heat a bit. In late stages the frame rate drops dramatically, to the point of the game becoming slightly “choppy” when there is too much action going on on a 4v4.
If I could select a frame rate cap (example: 40 fps) I believe both problems could be fixed.

If I could select a lower resolution while maintaining the same zoom I had acess to on a higher resolution that would also help a lot.

:arrow_forward: REPRODUCTION STEPS

:question: List the steps to reproduce the issue… Be descriptive!

Here’s how to reproduce the issue:

  1. Buy a cheap laptop like Lenovo Ideapad 310
  2. Play a 4v4 game
  3. Notice the heat on your laptop

You can cap FPS in any game using built-in NVIDIA software. Works fine for me.

Sounds hardware specific, I don’t have nvidia or amd GPU unfortunately.

You can use MSI afterburner + RivaTunerStatisticsServer to cap the FPS. But for multiplayer games I do not recommend it (you may slow down or make every other player games choppy)

Thanks for the reply, yeah it would be better to have it as an officially supported feature. The original game was capped at 20fps, I think it would be interesting if I could cap my game for example at 20, 40, 60 or 144fps. In my case I would choose 40 which is lower than the average performance my notebook is doing, but my game would still feel just as responsive, and my notebook would produce less heat.

Please devs, my notebook is heating a lot when I play aoe2, what if it is set on fire or explodes?
How would you guys sleep at night with the headline “Age of Empires 2 Player dead: After his laptop overheat due to rendering way more frames than he needed, a fire started, burning down his house and killing the player, his father, stepmother, two step-sisters and two-dogs. The fire spread to the nearby apartments and other 50 families died, all because the game had no configurable FPS cap, the player wasn’t able to launch the game in resolutions lower than 1024x720, and wasn’t able to load the graphics from the original version”

1 Like

Rivatuner Statistics Server works well for me for limiting FPS and thus the heat in AOE 2 DE and other games.


To be able to cap FPS to 30, like in AoE1:DE, would benefit low-to-mid-end PC users a lot!

I mean, right now we’re forced to use a lower resolution than that that we would like because of our PCs not being able to handle 30+ stable frames per second.


A workaround would be to use a third-party app, or to check the V-Sync box within the Graphics options, but that’s not exactly what we want.

Besides, if it is possible to achieve a 30 FPS lock in the prequel, it would probably be a piece of cake to do the same with this game, which runs on a newer engine, right?

Please!!! asd


Can confirm nvidia control panel has an option to cap the framerate aswell (as for v.442.50 drivers)


Bandicam offers an FPS cap option, which is nice. I use it as a complement to my graphics driver, which does not include such feature.

I tested it and it works. Really useful app.


Please consider this!

1 Like


  • Better overall performance;
  • The more settings the better;
  • No big differences regarding high and low frame rates;
  • Smaller impact on CPU and GPU;
  • It would prevent our systems to overheat;
  • No need to install third-party apps in order to achieve all those benefits mentioned above.

And maybe I’m missing a couple items.

1 Like

the fix may apply to your heating issue, but if someone lags, everyone lag in game.

The prequel already has this feature, so I don’t believe it will be an issue. Multiplayer can have fps cap disabled (forcibly) in case it does cause lag for others.
Multiplayer is also not for low end systems anyway, so limiting fps there kinda makes no sense. I see it useful mostly for single player matches and the campaign, specially.


not so much of prequel but this game is just badly optimized. removing fps cap does nothing for multiplayer if someone is just going to lag your game.

they would need to detach animation lag from UI lag

You can do that.

  • Download Riva Tuner Statistics Server (RTSS) version 7.3.1.
  • Start RTSS, add the aoe2:de executable found in steam/steamapps/common.
  • Enter the framerate limit e.g. 200.
  • Goto Setup and set the injection delay to 30000ms.
  • Start the game, wait 30sec.
  • Start a match. The fps should be capped now.

Additional notes:
Make sure that your game does not take longer than 20sec to load to main menu. If this is the case, set the injection delay to be the loading time + 10000ms.
In the ingame settings use the display mode fullscreen.
Make sure you have vsync disabled both ingame and in your graphics driver and you don’t run into the following bug: Vsync messed up for amd graphic users

I recommend to run the game with 4gb of video memory, if you have an integrated GPU, you may be able to assign that.
If the game runs out of memory or video memory, things get really bad.
Set the graphics to the very minimum, if your fps are not 1.5x as high as your display refresh rate at any time.
If you play, close all programs, including your browser, music player and also voip, if you don’t need it.
Restart the entire game after every hour of play, the performance degrades, the longer you run the game. Even if you close a match and go back to main menu, that doesn’t help.

Good luck, I hope for the best 1111

1 Like

Please, devs! Some people can run this at 30, but not 60 FPS or above! :slightly_frowning_face:

Congratulations to the devs, now everyone must have capped fps, even high-end pcs. Now I’m stuck with ■■■■■■ performance. :slight_smile:

I don’t know why they went that way. It is always better to have OPTIONS in order to achieve specific results…
Is it locked at 60 fps for you? Maybe it’s a GPU setting you have on without you knowing?