Achievement problems between steam/xbox accounts: Re-earning achievements

Does this also affects when switching an xbox account that is already logged in the first time when purchasing this game on steam? It seems to stop working on unlocking achievements for an xbox account that I switch from my previous one. I think the previous account works, but decided not to unlock achievements in a switched account, both the already earned and new ones that I unlocked on steam.

One year later and this bug still persists.


i have the same problem with several achievements like The King Is Dead, Long Live the King!, i have this one on steam with i can´t get it on my xbox account

1 Like

There is temp fix that might still work for you guys too, it needs installing the MS store version but you can get Game Pass still for like $1 for 3 months if you don’t have it.

I have this problem with a DLC achievement. Can’t get around it. Awful.

And installing a different version of the game from another store is not a fix.

1 Like

Okay, I came up with a work around.

I followed these steps just now to unlock “Unchivalrous Pragmatist” which was bugged for me. This works.

1. Enable Steam library sharing for your account and computer.

2. Create a new steam account, or otherwise log-in with one which does not have the achievement.

3. Request access to Age of Empires II DE (it will email you on the account registered to your main steam account).


5. Trigger the achievement, it should unlock on Steam and on xbox live.

Worth noting you can freely transfer game saves between account folders, I was able to use the ones I had from trying to trigger it again.

This proves that once triggered for steam, the achievements will not trigger again for xbox live.


Thank you for this solution. Worked like a charm.

1 Like

The latest patch that came out today ( seemingly fixes this issue. I was missing the win as Burgundians achievement on my Xbox Live profile, but was able to unlock it after re-earning it.

1 Like

I have a problem with the LOTW Event Challenges: I signed into Xbox Live to keep all the Icons/Mods, but all the Event Mods are only showing as Temporarily Unlocked, rather Permanently Unlocked. How to fix this? Can the Dev team please help with this?

I’m not sure if this is related, but I completed the “Pleasant Peasant” Steam Achievement today, but did not get the Xbox achievement at the same time. I assumed that perhaps I had built some farms before I logged into the Xbox account and it hadn’t been tracked. I ended up building all of the farms I had previously earned and the Xbox achievement did not pop. I am certain I built more than all of the farms needed for the achievement, so there seems to be some sort of bug.

Either the Xbox version of “Pleasant Peasant” does not work by itself or the Xbox version of “Pleasant Peasant” isn’t being registered because the Steam achievement is already complete. I’m not sure.


This just happened to me a few days ago… It’s really bugging me.

Thank you all for the feedback and i apologise for the “late” reply, we are now tracking this issue.
Have a nice day

Just had this happen again for the “Mango Shots” achievement. Unlocked on Steam but not on Xbox Live.

This happened to my last night trying to earn “Fast Food”. I got the Dawn of Dukes DLC yesterday, and last unlocked a Steam and Xbox achievement on October 31st. So I know the cross platform unlocks were working for me at one point. I booted up the game again tonight. Signed out of Xbox Live and signed back in. Started a new skirmish, met the requirements again, and the Xbox achievement has not unlocked.

I would really like to avoid creating a new Steam account like Tarvu suggested if I can help it. I mean I can download the game pass version but I do not want to re-buy the DLC again which I would have to do since that is the only achievement I have missed since this occurred and would not be cost effective for me. Is the developer working on a fix? I will submit a ticket anyways.

1 Like

Chu ku no 100.000 arrows triggered for me on Steam but not on XBLive

Fast Food cheevo too is bugged

I tried the family share version with steam to try to unlock some achievements, but still they are unlocked on xbox live. As their are several for me, i do not know what else i can do. I firstly did them on my main steam account while locked in on microsoft live. At the end of all the games I was always getting the “winning with a specific civilization“ achievement, so this is the proof i am connected to xbox live. But while playing, only steam achievements unlock but not the xbox live ones. The achievements i am talking about are:
“No suntzu light“ - shoot 100.000 arrows with chu ko nu
“Anyone order a pizza?“ - train 1.000 condottiere as a non-italian civilization
“Dark Humor“ - kill 20 villagers with Militia in dark age
“kaboom“ - kill 1.000 enemie units using Demolition ships

I guess some other achievements of this type will not pop up for me too, maybe the syncing is to slow between steam and microsoft if i do quick games? Or produce units to fastund because i use 20 buildings for production?
I made these achievements 3 times, always on fresh new steam accounts but they never unlocked on xbox, only on steam. Normal achievements like winning as bulgarian or spain always unlocked, as i always made a test game if i am really locked on to microsoft live.

I dunno how to unlock these though…

I like to earn all achievements of games if possible


Please help or find a way to solve this issue for all of us, devs!

I got the Masterpiece achievement 2 years ago with friends on Steam but Xblive deactivated. Last week I got it to my Xblive account

I used to think that once you get it on Steam you wont be able to get it on Xbox. I tried family sharing but the achievements i can’t get is:

Kill 1000 units with demo ships
Shoot 100k arrows with Chu ko Nus
Convert 1000 units
Convert 100 units with missionaries
Get 500 food from polish Folwarks

Weird as it sounds, it would unlock for sure if we played on Microsoft Store version, maybe the game can recognize achievements related to campaign or the ones you need to train 10 houfnice, research flamish revolution and get at least 50 flamish pikes.

Maybe xblive cannot detect progress (or cannot after any last patch)

1 Like

I still got the same issue. I can obtain campaign achievement without any problems or if i win a game with a civilization and get it unlocked on steam and xbox live but not the one where to kill, convert, produce huge amount of units…

Evenso i tried family sharing or using the account of my wife…

Game Version:
I am now in the same boat after getting the DLC on steam and an update on Dec 31st. I was working on DesertRose and had finished the William Wallace and Joan of Arc Campaigns and started Barbarosa. I got the Teutonics Victory, Furor Teutonicus, Losing Your Religion, Pleasant Peasant and Castle Crusher all in Steam, but no go in XBOX. I switched over to Leawildcat and backed up to try for Joan. Did the first 2 campaigns and got the Steam Achievements but nada in XBOX. I checked all the services and the XBOX server and neither of those worked. I’ll try with game pass, plus clearing all my caches and resetting the MS store. Sometimes that works with AOEDE.

BTW, I stumbled on to a fix that shut off a service for XBOX Live. Do the following to see if that helps any of you.

  1. Type services.msc in the search bar and select ‘run as administrator’
  2. Find ‘Connected Devices Platform’ and right click, selecting properties
  3. Changing the startup type from ‘disabled’ to ‘Automatic (Delayed Start)’ and then start the service
  4. Sign out of MS Store, Steam, XBOX Live, and XBOX Console.
  5. Reboot and sign back in in this order MS Store, XBOX Console, XBOX Live, and Steam.

When I did this all of my notifications went bizarre, but unfortunately it didn’t work for me this time. Since everything was just hunky dory before gettin the dlc and update in the same day, I suspect it was on of those. I am going to try the game pass and see what happens and I’ll also see if unistalling the dlc’s will fix it. At least I will be able to isolate it.

Okay so I got it working again, but I cannot tell you which one was the problem. I tried first just clearing cache, but no go still. So I tried game pass, still no go. So cleaned caches again and just for funzies I verified my game files in Steam. I also made sure I could bring up the XBOX game bar with the achievements and friends loaded, but still a no go. Cleaned caches and rebooted. I loaded and signed into XBOX console, then the XBOX Live app. I thought I had better check services so I made sure all of these services were running: Connected Devices Platform, Data Sharing Service, Gaming Services, IP Helper, Xbox Live Game Save (this one is giving me problems), Xbox Live Networking Service and had to start Data Sharing and Xbox Game Save. I then started Steam and went into the settings and under the DLC tab unchecked them both and then launched the game. Tried it and didn’t take, but just as I was about to close and quit for the night, I noticed in the upper right that my icon wasn’t present and just had the green Xbox logo and underneath my game name, it said not logged on to Xbox Live. So I clicked then Xbox icon and logged into my account, again. My icon, which is the same as here, came up. I tried it and I got the win for the Franks and it even gave me the William Wallace one that I had in Steam, but not in Xbox! I also earned both in Steam and Xbox Out of Their Element achievement.

Now for some reason the Xbox Live Game Save service, will not stay on automatic or automatic (delayed start) I have to start it every time and change it. I don’t know for sure that it has anything to do with the issue, but the description says that it “syncs save data for Xbox Live save” and am thinking if you are just using Xbox Live save in the cloud, but since it involves saving, figured it wouldn’t hurt considering the issues. I will tell you that for any game that has Xbox Live Achievements, the ‘Connected Devices Platform’ service has to be running or it won’t count achievements. I found this out with MS Solitaire, Jurassice World, and Forgotten City.

I will try tomorrow adding the DLCs back in one at a time and see if it is still not cooperating. I will also check the ‘counts’ achievements are logging properly. Which I suspect is part of the problem because you have a percent complete in Steam but Xbox is still not showing 0%.

1 Like