Age of Empires Definitive Ed keeps crashing

The attached error is displayed “Warning: a running process may be interfering with the correct operation of Age of Empires” and the game returns to the home page but with no options other than exit available. I am running Windows 10 and have no anti-virus other than Windows Defender running. I have installed no new software. I have reinstalled the game from scratch and the problem is still occurring.

Any help appreciated. Thanks.


I am also having the same issue :frowning: canm’t seems to find a solution anywhere

I have given up on it. Never got any helpful replies on the forum and no support anywhere else. If you ever find a solution please let me know. Thnx.

Hello, I also have the same problem. I am in the same configuration as you: Windows 10, only Windows defender in antivirus and I reinstalled the game.

I tried to whitelist the following files on Windows Defender: AoEDE_s.exe and BattleServer.exe

But it still doesn’t work …

am having the exact same problem as above people. I have reinstalled the game and uninstalled all of my anti-virus software and it has not fixed the problem. In the beginning, it says that there is a free update and gives you the choice of “Later” or going to the Microsoft store. When I choose the store, it only gives me Age of Empires DE II for $19.99 or paying $1.00 per month to be an Xbox member. I don’t want to choose either if the game will not play. Since it was playing fine before, I wondered if a new update caused the problem, but I don’t want to randomly start deleting updates. In the past, that has caused other problems. Has anyone found a solution for this problem?

I had two types of crashes. One happened while using the Steroids cheat, and last night, played a custom match against 7 AIs, but this time, no cheats were allowed in that match.

I hope devs fix the two crashes…

1 Like

Did you also try to search in MS Store app using the search icon for ‘Age of Empires: Definitive Edition’?
If you do find it there and then you open the product page, does it show a down arrow in the top bar left to your profile image? If so click that one to download the latest client.

If this doesn’t work I’ve read on the forums that you need to make sure your location is set to US, reboot your computer and then try it again, but I’m not 100% sure if this works in your case.

1 Like

I already contacted Microsoft to point them on the disgrace this game is. Wednesday, after the holidays (i am from Belgium), I’m having a new contact with them on how to reimburse my money.
This game is a failure and becomes more and more an embarrassement for MS.
I spent the better of three days to try to get the game operating propely and everything failed. I am a AOE-client from the first hour AOE I, II and III and it’s variations. This edition is really bad because of the crashes, the bugs, the desinstalling of the game by itself, the inaccesability of it’s files (XBox/MS Store) and so fort and so on.
I can only advice everybody to contact MS for a repay. Tomorrow I will put a link to this part of the forum on the Wikipedia-page and adjust the content of the ‘Reception’ part.
It’s not that i care to much about the money but i do care about a principle: If you release a game, make sure it operates propely and make sure it’s recreation and not torture for the buyers.

1 Like

That is a fair opinion. I agree with your principles, a little bit less with your patience. But that part is always a personal thingy. I said in another post that if the qc of their builds is not in order that it got no use to do events and monthly releases at all. Solution is to focus more on bug fixing and thoroughly test those fixes before release in every aspect of this game which is of course broad and time consuming.

I have tried everything that has been suggested and the game still crashes. I don’t understand why it worked perfectly before. I will also ask for my money back but I really like this game. I have also been playing it for years. I am wondering if anyone has had the same problems with AE DE II? I would buy it if I knew that it worked. I am wondering if MS is making AE DE crash to force us to buy the new AG DE II. Any ideas or info on this?

1 Like

I do own them both from MS store and both work in my case. So there has to be something else that breaks it. Which Windows version and build is installed?
You can check this by launching ‘winver’.

Also you could try to sign out from Xbox Companion-console and MS store together and after that check manually for updates below .... Sometimes the problem is missing other updates like for Game-services and so on.


One of the first things I did when this problem occurred was to uninstall, download and reinstall and I still have the problem. It has been six months since I looked at this so I will try again today and see if anything has changed.

As per my previous response I said I would uninstall and reinstall from the MS App Store. Couldn’t even do that - all I get is the attached error. I’ve now officially given up on this.

I also experience crash all the time with the same error message …I had it in april too but it was fixed during the patch of may… since the new patch it came back crashing with this message and tempering detcted

I normally:

  • verify file integrity (this with Steam… I don’t know if Microsoft Store has a similar option/feature)
  • see if my antivirus isn’t the one causing the issue (by adding the game to the exclusion list)
  • reinstall DirectX (or install latest update)
  • update Windows to the latest version
  • restart my computer and restart the game

But it’s really annoying not really knowing what’s wrong with the game and it suddenly crashing, even when playing the campaign or custom matches.

1 Like

Okay so I know that Trend Micro is really bad about causing this error especially if using the MS store version, but Steam as well. My guess it is also bad with Malwarebytes, Norton, and McAfee, and all of my games have had issues after Windows Defender updated, so I turned that one off. I run Trend Internet security and I have my whole Steam folder in the exceptions list so that solves the problem for Steam. If you are using the Windows Store version it’s a little trickier to add that folder to your exceptions list. You have to take ownership of the C:\Program Files\WindowsApps folder. Here is a good video on how to do that. Once you have that settled you can go into your virus/internet security program and add the whole C:\Program Files\WindowsApps to your exception list. This actually solves most of the warnings. Be aware we got this warning on my desktop using the MS Store version after we had done this. I did not realize Steam and UPlay where both open in the task bar. Those overlays will get you and make sure you actually quit them if using the store version. The only successful overlay for the MS store version is the MS games bar and XBOX overlay.

1 Like

Another crash

Win 10 Home v:1903 Build:18362:1016

Faulting application name: AoEDE.exe, version:, time stamp: 0x5efd316a
Faulting module name: MSVCP140.dll, version:, time stamp: 0x5d30eae5
Exception code: 0xc0000005
Fault offset: 0x0000000000019248
Faulting process id: 0x2750
Faulting application start time: 0x01d681e8bce6b558
Faulting application path: C:\Program Files\WindowsApps\Microsoft.Darwin_100.1.38862.0_x64__8wekyb3d8bbwe\AoEDE.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.Darwin_100.1.38862.0_x64__8wekyb3d8bbwe\MSVCP140.dll
Report Id: 4166d1bc-38fd-4557-a12f-b6510fff0318
Faulting package full name: Microsoft.Darwin_100.1.38862.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

C:\Program Files\WindowsApps\Microsoft.Darwin_100.1.38862.0_x64__8wekyb3d8bbwe\AoEDE.exe
C:\Program Files\WindowsApps\Microsoft.Darwin_100.1.38862.0_x64__8wekyb3d8bbwe\MSVCP140.dll

West you are playing the Microsoft Store version I see. That one is now a bigger problem with the changes Microsoft made to the Defender. You can follow the video in post above on gaining control of the Winapp folder and adding it to the Microsoft Security exception list and any other antivirus/security software you have, but try resetting the game first. If you go into apps in your settings you can scroll down to AOEDE and click on it. It should have a more or advanced option in red under the title. If you click on that, then you can click the terminate the game and reset the game. That should fix the dll files that have gotten corrupt. If it doesn’t and the winapp solution doesn’t solve the problem, let me know and I’ll give you a couple of more suggestions.

I’m running into the same issue in Windows 11. Is Windows 11 supported?


I have in on a windows 11 computer and its working fine.
What version of the game are you using and what kind of software you have that could be interfering?

1 Like