AI does not have TC identifier in its script

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 51737
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Upon starting a single player skirmish game with an AI player, the game throws an error that the AI script’s tc identifier was not found. The AI then wanders randomly with its villagers (due to, I assume, thinking it doesn’t have a TC) and no longer plays the game.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

This happened with any civs I tried, and any level difficulty of the AI

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Start a standard skirmish game with any level difficulty AI
  2. The error will be thrown once the game loads.

:arrow_forward: EXPECTED RESULT

The AI behaves normally.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

edit: gathering and uploading this shortly

TC-IDENTIFIER-BUG.aoe2spgame (200.5 KB)

Duplicate of AI Script Error

I solved this by deleting the contents of the resources/_common/ai directory and then verifying integrity of the game cache to re-download the removed files.