AI Stops Working In Multiplayer Games

Here is the save file that shows the glitch:
https://filebin.net/vcbk8o3egav218gb

Bump. Any update on fixing this bug?

1 Like

I had AI stop trying last night, so I’m curious if this bug is being tracked still, too, My game was 1 vs. 2AI. They were both doing pretty well for a while, but at some point, one of them gave up trying.

After getting rid of the one who was trying, I went to go attack the dormant one and noticed he had a bunch of villagers just standing by a forest, not doing anything. (I didn’t notice he was pretty much completely dormant until I saw this. His quietness for a long while (attacks stopped) made me think he was just working on his economy or something.)

1 Like

Me and two friends have played about 20 matches in the last two months, first against the medium and most of the time against the hard ai. I assume that the enemy AI stopped working about every second match.
One time this was obvious when it happened to an allied AI first. It had it’s base taken down by the enemy in a short amount of time and just a few villagers remained and continued chopping wood instead of rebuilding a town center, which it had the resources to do. We saved and reloaded the game and it stopped chopping wood and instead sent one villager to build a TC and all the others to build a lumber camps in the middle of the enemy base. During this time two of the three enemy AIs stopped working too.
In a fairly recent game a similar thing happened as can be seen in the timeline. There was no reason for red to not advance to the feudal age - this even was a regicide game so everyone started with a lot of villagers. Blue and cyan stopped advancing after feudal age too. The AI was set to hard and the pop-cap to 250. We also made a few save files in case this could help. It also doesn’t make a difference who hosts the game.


It would be great if this could be addressed, because very hard AIs wiped us out very quickly the last two times that we tried while all the weaker ones are no challenge at all.

2 Likes

My friend and I have this issue happen constantly with th AI. We are also posting a saved game for them to check as well.
the thread is: New AI stops playing the game when in 8 player games at 200 pop

This issue has happened with all of the builds thus far.

My friend and i enjoy playing games with both of us and 6 other AI’s in one match. We do 200 pop and all of the AI’s on the hardest difficulty. It doesn’t matter what map we are on, what civs we all are, or what the teams are set to but the AI stops playing the game around the time everyone upgrades to the 4th age. Vills stop reseeding farms, their troops group up on a random building and don’t move, and wood cutters stand still by the trees. We have tried to “poke” (attack a building or other item) the enemy AI’s to try and wake them up. It doesn’t always work but sometimes it gets the AI working again (by that time thought, the AI is so far behind that it is worthless). This issue makes large multiplayer games worthless.

Start up a multiplayer game with 7 other AI’s, the whole map explored (so you can watch the AI and what they are doing), set the population to 200, and play away and see when the AI stops doing anything.

5 Likes

There’s been no official response to this issue since the beginning of the beta :frowning:

This issue just happened again at 300 pop with only 2 AI’s and 2 humans playing.

2 Likes

My friend and I have had similar experiences with 3-4 AIs and 500 pop. Also mixed result whether the AI will start again with enough fighting.

2 Likes

Hello friends! There are two things we could use to verify this behavior:

  • A replay of the game where you saw this behavior.
  • A save game file where and when the issue happens.

If you can provide a link to these files in a Google Drive or One Drive, I’ll get them passed to the team so they can take a look. (For my reference: 171564)

Thanks for the report!

3 Likes

saved game: https://drive.google.com/file/d/1wLTyHrUInDwVHh8CvRzS0SWWSny6lo2A/view?usp=sharing

replay: https://drive.google.com/file/d/1yPjgaAQjqu3SfN9AhS6Zsh9zxHidk7ve/view?usp=sharing

2 Likes

Thank you for the information. This will be most helpful!

Game Version:

  • Build (34397)
  • Platform (Steam)

Issue:

The new AI is utterly confused on hard difficulty (or lower) with a population limit of 500 on a ludicrous map. It doesn’t boom, it doesn’t expand its military very much and it seems to stay under a population limit of 170 despite the actual limit being 500.
Note that this issue doesn’t occur on hardest difficulty where the AI plays exactly as expected.

Reproduction Steps:

Based on my testing, I believe the issue is present for any standard game on any map with any civ and for difficulty setting at hard or lower as long as the population limit is set to 500. But just in case here are some settings that I’ve personally verified to reproduce the bug:

  1. 500 population limit
  2. Ludicrous map size
  3. AI difficulty either Hard
  4. Yucatan map
  5. Conquest victory
  6. Standard resources
  7. AI playing Korean or Celts

Disclaimer:
PLEASE UNDERSTAND THAT THIS IS NOT A BALANCE CONCERN. IT IS A VERY CLEAR BUG THAT MAKES THE AI ON HARD WAY EASIER THAN INTENDED.

Here is an example of a game I played. As you can kind of tell by the pictures I let the AI do its thing for more than an hour before making any sort of advancements against them. Yet their economy is incredibly poor, they never built a large army and they never come anywhere close to utilizing the population limit. Thus once you engage them they predictably go down incredibly easy.

2 Likes

Game Version: 101.101.34699

  • Build (4580616?)
  • Platform STEAM

Issue:

when DE AI is set to hardest and is assigned Berbers vs Khmer on Arabia, it goes full on doo doo dumb. 15 minute feudal time, 24+ minute Castle age. doesn’t make military units, even when being attacked. uses market to try and castle drop multiple times on defense once it hits castle, still wont create military units. continues to spam vill production.

Reproduction Steps:

Small map (3 player)
DE AI on hardest, Berbers
Player selected Khmer
standard resources
standard victory
200 pop
normal speed
standard exploration

1 Like

[Merged a bunch of threads on the topic.]

Just a reminder that we could use two things to help us see and identify the problem:

  • A replay of the game where you saw this behavior.
  • A save game file where and when the issue happens.

Unfortunately we have not been able to reproduce this problem internally, which is why we could use replays of the issue. Pass them my way and I’ll be sure they’re sent along to the team.

Thanks for the report!

You haven’t been able to reproduce the AI standing around doing nothing, or that it always plays at a 200 population when set to something higher?

Also, have you had a chance to look over the replay that was posted of the AI standing around? Maybe it is a reseeding farm issue, but then all of the lumber vills shouldn’t be standing around as well. Or maybe it’s an expansion issue where they have no more space to expand and just glitch out.

These are two savefiles and the recording of the game that I posted the timeline of:
savegame.zip.txt (5.6 MB)
Just remove the .txt ending to extract the zip file.

Bumping this thread. I have played several reloaded multiplayer games where this bug has occurred.

The (hard) AI seems to do basically nothing in the reloaded game - no eco, no military, no unit commands.

1 Like

Any fixes for this? Its insaninly frustrating to play for almost an hour and this starts to happen.
It happened to me playing with 2 humans and 2 to 4 AI… they suddenly stop responding and In my case since I created the match, my units and buildings just stop responding too. Sometimes they respond for a few seconds (just my units).
Here someone recorded the exact same behaviour although it never kicks me out in my case.

2 Likes

Just a note, its a similar behavior as when I save a multiplayer match… workigin fine, 2 humans 2 to 4 AI… no problem, I save it, and when I restore it all AI just stay still like zombies (actually zombies would attack at least).