AI Stops Working In Multiplayer Games

Game Version: Age of Empires II Definitive Edition (Steam)


There have been three games now where my friend and I are playing on a Giant or Ludicrous Map size, Black Forest, where about 5-10mins into the match, the AI players stop working. Villagers are just standing around. We’ve tried launching a restore of the game and the workers will start going back to work for about 1min and then they stop again. Or if myself or my friend resign, then the AI starts working again.

Additional details: Resources set to Ultra High, Difficulty set to Hardest, Visibility set to All Visible. Also, my friend and I are on a team. AI players are either two on a team or each on their own.


Bumping the thread. I haven’t seen a response yet from anyone and this bug isn’t listed on Known Issues.

Hello NoUseMerk, thank you for the report!
Would you be able to attach a savegame where this issue happened? Regardless we will try to reproduce it, thanks!

I can look at uploading a save game file sometime in the next day or two. I have one I know of for sure, as my friend and I attempted several restore games from it trying to find a way to debug it.

This bug still exists. I tried playing a couple games with my friend online over the weekend and it happened twice out of four games. I think it has something to do with us being on a team vs AI players on their own. Once our team score get higher than an AI player before the Peace Treaty is over, all their villagers stop working.

Also, I noticed a side issue with the AI on Team Island maps. While their workers do just fine, I noticed that the computer players didn’t really build much of a standing army. Again, we had it on a 90 minute Peace Treaty, but when the timer was up, my friend and I were able to just steam roll over the AI players. And we had the difficulty set for Hardest.

1 Like

This issue still is happening. My friend and I just played another game and the AI stops working around score 5,000. How do I upload my save file so you can see? I don’t know where the save files are located.

Found the save file. Here it is:

Here is the save file that shows the glitch:

Bump. Any update on fixing this bug?

1 Like

I had AI stop trying last night, so I’m curious if this bug is being tracked still, too, My game was 1 vs. 2AI. They were both doing pretty well for a while, but at some point, one of them gave up trying.

After getting rid of the one who was trying, I went to go attack the dormant one and noticed he had a bunch of villagers just standing by a forest, not doing anything. (I didn’t notice he was pretty much completely dormant until I saw this. His quietness for a long while (attacks stopped) made me think he was just working on his economy or something.)

1 Like

Me and two friends have played about 20 matches in the last two months, first against the medium and most of the time against the hard ai. I assume that the enemy AI stopped working about every second match.
One time this was obvious when it happened to an allied AI first. It had it’s base taken down by the enemy in a short amount of time and just a few villagers remained and continued chopping wood instead of rebuilding a town center, which it had the resources to do. We saved and reloaded the game and it stopped chopping wood and instead sent one villager to build a TC and all the others to build a lumber camps in the middle of the enemy base. During this time two of the three enemy AIs stopped working too.
In a fairly recent game a similar thing happened as can be seen in the timeline. There was no reason for red to not advance to the feudal age - this even was a regicide game so everyone started with a lot of villagers. Blue and cyan stopped advancing after feudal age too. The AI was set to hard and the pop-cap to 250. We also made a few save files in case this could help. It also doesn’t make a difference who hosts the game.

It would be great if this could be addressed, because very hard AIs wiped us out very quickly the last two times that we tried while all the weaker ones are no challenge at all.


My friend and I have this issue happen constantly with th AI. We are also posting a saved game for them to check as well.
the thread is: New AI stops playing the game when in 8 player games at 200 pop

This issue has happened with all of the builds thus far.

My friend and i enjoy playing games with both of us and 6 other AI’s in one match. We do 200 pop and all of the AI’s on the hardest difficulty. It doesn’t matter what map we are on, what civs we all are, or what the teams are set to but the AI stops playing the game around the time everyone upgrades to the 4th age. Vills stop reseeding farms, their troops group up on a random building and don’t move, and wood cutters stand still by the trees. We have tried to “poke” (attack a building or other item) the enemy AI’s to try and wake them up. It doesn’t always work but sometimes it gets the AI working again (by that time thought, the AI is so far behind that it is worthless). This issue makes large multiplayer games worthless.

Start up a multiplayer game with 7 other AI’s, the whole map explored (so you can watch the AI and what they are doing), set the population to 200, and play away and see when the AI stops doing anything.


There’s been no official response to this issue since the beginning of the beta :frowning:

This issue just happened again at 300 pop with only 2 AI’s and 2 humans playing.


My friend and I have had similar experiences with 3-4 AIs and 500 pop. Also mixed result whether the AI will start again with enough fighting.


Hello friends! There are two things we could use to verify this behavior:

  • A replay of the game where you saw this behavior.
  • A save game file where and when the issue happens.

If you can provide a link to these files in a Google Drive or One Drive, I’ll get them passed to the team so they can take a look. (For my reference: 171564)

Thanks for the report!


saved game:



Thank you for the information. This will be most helpful!

Game Version:

  • Build (34397)
  • Platform (Steam)


The new AI is utterly confused on hard difficulty (or lower) with a population limit of 500 on a ludicrous map. It doesn’t boom, it doesn’t expand its military very much and it seems to stay under a population limit of 170 despite the actual limit being 500.
Note that this issue doesn’t occur on hardest difficulty where the AI plays exactly as expected.

Reproduction Steps:

Based on my testing, I believe the issue is present for any standard game on any map with any civ and for difficulty setting at hard or lower as long as the population limit is set to 500. But just in case here are some settings that I’ve personally verified to reproduce the bug:

  1. 500 population limit
  2. Ludicrous map size
  3. AI difficulty either Hard
  4. Yucatan map
  5. Conquest victory
  6. Standard resources
  7. AI playing Korean or Celts


Here is an example of a game I played. As you can kind of tell by the pictures I let the AI do its thing for more than an hour before making any sort of advancements against them. Yet their economy is incredibly poor, they never built a large army and they never come anywhere close to utilizing the population limit. Thus once you engage them they predictably go down incredibly easy.