Always prompted "Mod failed to publish." when update my mod

I tried everything to update a published mod, but the page always prompt “Mod failed to publish”, and only the description has been updated. It is just a scenario. Why?
I can still publish a new mod, so is it the only way that delete the outdated mod and publish a new one?

1 Like

@DodoNotDoDo Your help is needed :slightly_smiling_face:

It’s being stopped due to inappropriate content. Does it contain any images that might be misconstrued as being inappropriate?

More clear error messages are needed so that mod uploader knows, what is wrong and can make appropriate changes

1 Like

I also tried to upload a zip only containing _resource/… folder and the scenario file names “Battle Over Grass 0th Season.aoe2scenario”,
and failed as well.

I did some cleanup on the record in case that was causing issues. Give it try updating again now. If still a problem, I may need to have you send me the mod so I can see if I can determine why it’s still getting blocked.

Great. I tried to update the scenario file once again after saw your reply, and finally succeed.
However, when I continue to try to upload the preview image, it prompt “Mod failed to publish” again, even though it is just a full map screenshot with a title text.
I also tried to update the description only and be prompted that message as well. (Though the description successfully updated in effect.)
Thanks but… does the “cleanup” take effect only once?

I forgot to click reply. @DodoNotDoDo

I was able to bypass the image check and got your image published. I’m not sure why it’s getting flagged as inappropriate, it’s clearly not. Hopefully this will allow it to be updated by you going forward, but I’m not 100% confident on that. I’m going to check with the team that manages the image scanning and see if they can provide any further insights. If you run into further problems making updates, let me know.


After multiple attempts to release my new mod, I’ve found that the problem is indeed with the thumbnail image. Likely whatever tool is being used to analyze the images for inappropriate content is extremely strict and produces false positives on just about every image.

1 Like

@DodoNotDoDo Please disable the check for inappropriate content from images. Such an automatic system will always make errors and incorrectly flag images as inappropriate even if they are not. Manual flagging system by users is much better.
Also nothing happens, when once in a while someone uploads inapprioriate image. Game rating is teen (13+) and such people are used to seeing all kinds of things on internet anyway.

1 Like

@DodoNotDoDo I can’t upload mod via in game publish nor online zip. in game gives error such as either unknown reason or missing thumbnail image.