AOE 2 DE running at only 4 FPS suddenly!

I’m trying to figure out what changed - I don’t recall patches or any changes to my system in the last couple of days but yesterday I noticed AOE 2 DE was running veeerrrry slowly! Even in the menus, they take forever to refresh and the game only runs 3-4 FPS on an i7/1660 Super that never ran below 60 fps previously. Tried different resolutions, restarting several times, updated video drivers, etc…nothing made a difference. All other games run fine.

Then I tried AOE III DE and it DOES THE SAME THING! Running very, very slowly. I’ve heard others are having similar problems.

What happened? Any ideas on how to fix it?

4 Likes

Update: uninstalled, reinstalled - same problem. Verified integrity of files, etc…nothing is working to fix these two games.

Another update: this does not happen on my laptop which is running all the same versions of the games (i7/960 GTX).

I have the exact same problem. Since yesterday the game is now running at about 6fps both in the menu and in-game. I have changed nothing in the settings etc. since then. Prior to this the game ran perfectly at a smooth 60fps minimum.

1 Like

What video card do you use? Wondering if there is a common thread…

Radeon ™ RX 470. How about you?

I think the issue may have been triggered by a recent Steam update.

Hi All. same problem. thought I was taking crazy pills. tried everything. I have a RTX 3060, new build. strangely the prob happened before I installed graphics card driver, was fixed for 1 day after installing drivers, then crap 2 days ago approximately til now. hope they fix it soon.

We don’t even all have nVidia cards - I have an MSI 1660 Super. I do not see the common thread here. I also don’t see a whole lot of people complaining about this issue so I wonder how much attention it will really get.

I haven’t made any changes to my computer over the last week so I have no idea what could trigger this other than an update they made to the game itself.

In the past, I’ve had tons of issues with the game crashing and the Windows system logs show that it ran out of virtual memory, so I’ve quadrupled the amount of virtual memory available to Windows, which stabilized that issue. No idea if this could somehow be related - have you made any changes to virtual memory?

I’ve also tried lowering the resolution, turning VSync on and off, etc…nothing makes any difference at all. It’s interesting that you can see the slow-down the moment the main menu slowly draws across the screen.

I have submitted a ticket to support for this. I’ll let you know what I get back…

1 Like

In task manager, what does it say about the CPU usage, memory usage, and GPU usage? It might help the developers to know what the apparent constraint is.

Here is an example. With this, I can tell that neither my network, memory, nor GPU are maxed out. Also, the GPU temperature is acceptable.

That is the first thing I checked - when I run the game, the CPU is below 30%, GPU is below 20%, memory is about 50% and the network is not doing anything, so there is no indication that any of my hardware is being pushed at all - and there certainly isn’t a bottleneck of any kind. GPU temperature is around 33C. No issues that I can find - it just seems like the game isn’t leveraging the hardware the way it should - not really even engaging the video card.

1 Like

How many cores in your CPU?

AOE2 is primarily two-threaded (it does have a number of other threads that are usually idle.) That means if your CPU has two cores, then the CPU could max out at 100%. But, if your CPU has 4 cores, it would likely only reach 50-60%, because AOE2 simply can’t take advantage of the additional cores.

I mention this because at 30%, the game could be maxing out on your CPU. For example, my 20-logical core CPU can only max out 5% of the CPU (1/20) per thread. Since AOE2 only uses 2 threads, it can only max out 10% of my total CPU. If there was a code defect blocking performance, it would still not show more than 10% of the CPU being used.

I have the same problem, Nvidia RTX 2070 with 32 RAM nothing abnormal with performance monitoring. Gaming mode on, Xbox bar deactivated as well as V sync, i tried also with the microsoft store version (i own two copies) as well as steam and same problem. happening since the beginning of this week approx. All windows and nvidia updates installed as well as a full update check an all components without success in fixing the game. The game seems to be able to open the option tabs well if that helps.

Yes, I understand but even if I look at the individual cores view of Task Manager, no single logical/physical core is anywhere close to 100% - all remain in the 30-50% at most. It’s not a CPU bottleneck. I still believe it’s a GPU issue.

Thanks. I’m still working with Support…I have enabled the enhanced logging and sent them my log files. I also uninstalled the Steam client on their recommendation, not realizing that deletes every game I have…sigh…and reinstalled the game from scratch.

Still no change.

Please keep people posted, i think i have the same as you

1 Like

The other day I noticed that if there are any connectivity problems (regardless of where in the chain even when you have a good signal) AOE2 seems to tell the OS to disconnect/reconnect to the network (my wifi icon changes to no-network-connection icon and then back to wifi). At the same time, AOE2 seems to consume memory as the game is being buffered for cloud upload. This causes everything to slow way down for a period of time, but eventually clears up.

I’m not saying this is what you are experiencing, but maybe watch for anything around the network just in case.

Yes, the support team had me reset my router, etc…but I had no issues with network. I’m hard-wired as well.

1 Like

nice work chasing it up RedHagar. still no resolution? I suspect its graphics card related too.