Aoe 2 de wont launch

:hammer_and_wrench: Ensure that your computer meets the minimum requirements to play the game.
-> OK

:hammer_and_wrench: Update your display drivers.
-> Up to date

:hammer_and_wrench: Check your antivirus settings.
-> Using only Windows Defender, still the same issue after disabling it

:hammer_and_wrench: Manually update Microsoft Visual C++ Redistributables and restart your machine.
-> Did not help

:hammer_and_wrench: MICROSOFT STORE: Run the Windows 10 Store App Troubleshooter.
-> Did not help

:hammer_and_wrench: Disconnect additional monitors.
-> Did not help

:hammer_and_wrench: Uninstall and reinstall Age of Empires II: Definitive Edition .
-> This is the only temporary solution, but after the second launch the issue is back again

:hammer_and_wrench: Move the app to a different drive.
-> Tested this on a different Computer but same issue. On my primary PC I currently have only one drive but still more than 1TB left.

1 Like

All tried, nothing works. Really frustrating.

@ADragon8602 Could you or someone from your team reproduce this issue?

Glad not to have bought the game and have it included in Game Pass Ultimate. Feels like no one is really interested in solving this…

I’m sorry to hear that. Do other games included with Game Pass Ultimate work fine on your PC?

Only had problems with Imperator: Rome in the beginning, anything else is running without any problems.

Could you post your log file here or link to the latest log?

Just scroll… :wink: Same log as mine.

Do you also have a wide screen UHD monitor? Strange issue it is indeed.

I actually do have an UHD and 2 additional monitors.
I disabled the UHD and one of the smaller ones, so only one monitor (Resolution: 1920 x 1080) was plugged in, but still the same issue.

So your laptop screen is UHD and not 4K. What happens if you disconnect all external monitors and just use your laptop screen? Usually it’s the other way around, Full HD laptop and additional 4K monitor. Did you also try with disabling things like NVidia shadow play and so on. Let’s hope next build will fix these issues for you guys.

Not, it is my desktop PC :wink:
But folks, I found out what is causing the problem: The Windows Display Language!
I changed the Windows Display Language from German (Germany) to English (United States) and the issue is gone. I changed the languages back and have directly the issue back.

It is really only the setting, changing other locales or the preferred language does not affect the game.

@Pommfriedel What language are you using? For reproducing you may need to download this language pack (English (United States)) from here: https://www.microsoft.com/de-de/p/english-united-states-local-experience-pack/9pdscc711rvf?activetab=pivot:overviewtab

2 Likes

Then maybe you only need to add the US (international) keyboard definition. My system is Dutch localized but we don’t have (or better to say don’t use anymore) specific Dutch keyboard layout. For Germany using localized keyboard layouts (with ü) is still very common.

I changed only the Keyboard Layout to English, but the issue persists.
When using the English UI but using the German Keyboard Layout the game works. It is really the Windows Display Language.
Additionally: I changed ingame the language to German (Deutsch) and the bug doesn’t appear there after the restart of the Game.

But it could be, that only the german language is affected by this.
Can you perhaps check if you find some comments complaining about this issue of the
Enhanced Graphics Pack in the Dutch Version of the Microsoft Store? Because in the German one I found 8 comments (out of 18 total) complaining about this.

Not in MS store app, but online i did find a recent complaint (30-jan). ‘Lukt niet.’
https://www.microsoft.com/nl-nl/p/enhanced-graphics-pack/9n2522zb038z?activetab=pivot:reviewstab

Thank you for the search, I appreciate that.
But I don’t think if he has the same issue, because a “Download failed” could be everything :wink:

Agreed. I also think that there are two different issues with the EGP add-on. One related to crash at startup or launch of AOE II DE (like yours) and one related to being unable to download it at all. This could be because it was released before latest build already and the version number check doesn’t work like it should anymore.

Hi, welcome here. My display language is set to Dutch but I’ve added other languages too.

Maybe this setting is related to the problem. Although it says website I’m quite sure this counts for all apps on your Windows 10 system. Disabling this might cause this strange crash related to default language settings. Not sure so please check and test it and let me know.

Changing the Display Language solved it.

2 Likes

Still remarkable that I don’t experience this issue at all.

Maybe it’s because my OS install base (many years ago) was EN-UK version and I added the other languages later and then changed default and primary display language to Dutch.

Do you by any accident happen to use WSUS? If you don’t know what it means ask your system administrator.