AoE DE LAN issue

I also experience issues with playing LAN games where no game lobbies can be found after installing the latest version of Age of Empires Definitive Edition (AoE DE) from the Windows Store. In my case a test of disabling Windows Defender Firewall in Windows 10 (build 1903) solves the problem instantly and lobbies are now visible, and connecting to them and play LAN game is working perfectly. As this is not a viable permanent solution, I have unsuccessfully tried two different solutions.

The first was to create an inbound allow application firewall rule for the AoE DE executables (*exe), but as the installation folder (WindowsApps) is a special system protected folder I cannot view them nor browse for them in the Windows Defender Firewall create new firewall rule wizard. As of now I have not dared to modify the ACL (Access Control List) for the WindowsApps folder to grant my user account sufficient permissions on the folder.

The second try was to take a long shot and create inbound port allow firewall rules in Windows Defender Firewall for the following ports and protocols TCP 8888, 3478 (UDP & TCP), and 5222 (UDP & TCP) described here for Age of Empires II Definitive Edition as I have been unsuccessful locating the ports and protocols for AoE DE.

Can you please inform what firewall rules are needed to run LAN games in AoE DE latest version or what to do to get LAN gaming to work again?


I am having the exact same issue.

I even went so far as to examine the connections while in lobby and in game using tools such as zenmap, ncat, and netstat.
Can’t think of any reason you should have to disable the firewall to get a connection.

Any answers here?

+1 same issue.

I’ve sent feedback to Microsoft support but no answer for the moment.
Also I bought twice the game, one for me and one for my daughter but we can’t play online together because her account is blocked by Microsoft policies even if I had allowed her account to play on internet and join parties!
In 1997 it worked perfectly in multiplayer, in 2020 it’s not!

I have exactly the same issue. I hope MS sort this out!

Known problem for playing game on LAN: LAN play unavailable . FAQ gives ports to open on FW: that does not help.


Same issue, but when I disable the firewall it will work, I still would like the issue to be resolved.

1 Like