Aoe II DE challenge bug


I am needed you support, you nobel ones!
I have been trying to accomplish the Mongolian New Scenario for the second last challenge. I have finished two games of that scenario with scores above 32k, and still the challenge is not completed. And no, I dont have a challenge cooldown. Ive been trying since yesterday to complete and it wont let me do it…
In this case is any solution to grant me that rewards of the last two challenges since the game is bugged and it wont flag the second last challenge as passed? :confused:

Best regards,

1 Like

I think you’re not alone :wink:

1 Like

Lol dude. But I have tried for two days to complete that (and yes i had the previous achievements completed so i could have this one unlocked) and always scored 30k+… (trying for two days removes the hypothesis that it had a cooldown…

1 Like

Yeah, that’s too bad :-/ Sorry to hear. That is like what others are reporting in that other thread, though, right?

Just making sure I understand b/c “lol dude” can be taken in two ways there. Either you completely relate to that other thread and are in disbelief by how many reports there are, or I failed to diagnose your issue correctly :joy: I think it’s the former, but just checkin’

1 Like

Its because you gave me that thread where ppl had same problem as I do.
Bumping to topic… Any dev help? :confused:


I anticipate nothing will be done about this. I have this same issue, but it seems like a very small number of people are experiencing it so it will not get much, if any, attention. It has put me off of playing AoE2:DE as I am one of the few that plays only against the AI. Not being able to enjoy an entire event is a big deal to a player like me, so I basically stopped. I’ll miss out on some of the fun of this event and just wait until the next one. It’s not the end of the world obviously, and there are a lot bigger things in this world to worry about, but I have only so much time available for things like AoE2:DE so when it’s not fun I simply move on for a bit. I’m sure I’ll be back - I just hope that I won’t have the same issue the next time.

I’m rather new to the forums here, so when you say “[…] in disbelief by how many reports there are…” it made me wonder b/c it seems to me that there aren’t that many reports. I’m basing that on the lack of any official acknowledgement of a problem and the fact there were so many “you’re doing it wrong” responses from so many people. But being new, perhaps I’m simply not aware of what counts as a lot of responses.

I haven’t read thru the thread in-depth since I didn’t experience the issue, personally (at least not with the first Mongol points challenge). I didn’t attempt the remaining challenges.

However, with all the threads being merged into that one and a number of people reporting (I thought) the same thing with no human error involved (I thought), I just assumed it was a fairly common occurrence… like maybe a bug/issue with the challenge.

If you read that thread and had a different take, then I stand corrected :slight_smile:

No issues from me with your comments. I was only explaining that I thought only a small number of people had reported the problem. I take no issue with your thoughts I apologize if my comments put you on the defensive. I did not in any way mean to insinuate that you were totally wrong. The lack of official response of any kind made me think they believe we are stupid and don’t know how an event works - many comments from others came right out and said it wasn’t a bug, rather it was a bunch of plebs whining about something that didn’t even exist.

1 Like

Oh, no worries, NuclearMoose64. I didn’t take offense by your comments at all, and wasn’t being defensive. Sorry if it came across that way. I was just matter-of-fact about it, as I’m okay with whatever the real situation is. Thus, the smiley face. If I overstated the frequency of the problem, I’m totally okay with being wrong and the reality being portrayed instead. No worries

1 Like

Still no staff member has replied to my thread… :confused: