AOE IV Hard Crash Bugsplat Error

Looks like the new patch 9.1.370 fixes the problem.

I haven’t played this game for months. I just started playing with the new patch and got this error. Are you still limiting frames?

Limiting frames doesn’t seem to work. I tried everything. Even on the current patch. Only solution was to buy the game on Steam. It’s a real shame. Ames me feel like I’m wasting money on Gamepass. I searched for a solution and couldn’t find one.

1 Like

It didn’t prove to be the case. Current patch is still broken. But it’s too late for me to return the Steam version anyway.

No limiting. every option max. played few long games without crash. that was not possible before patch. seems to work. I will report if it crashes again

I had the problem with the steam version. now its ok after the patch. hope it keeps workin

My issue was with the Game Pass version. I couldn’t even load into the game. It crashes before reaching the menu. It’s impossible to load into the game. Steam version works fine. Windows version is super broken.

Having this problem for about a months. Now it’s working, don’t know what they did

Nah, that was just for a day…

same for me. I think i reinstalled this game 8 times in the last year for several reasons. always after a update. Microsoft store is just horrible.

I have a 7900 xtx and noticed that this started happening for me - I have kind of isolated it to v-sych and limiting the frames to 60 in game - but that seem poo, it might also not work for others, but it seem a little more stable that maxing out the fps to unlimited (note I have tried up to 175 fps and that crashes as well).

Hey, I found a soulution that might be working, I’m in the phase of testing right now.

All screenshots have error 0x80000000000000, and with the help of google, I found out that the error in question is, in most cases, happening because the redistributables for the game might be corrupted.


(Couldn’t find anything on AOE4 so far, but same thing happens with games using c++ redistributables)

They actually refer to this issue on this page.

Having that in mind I’m reinstalling all the redistributables I have on my PC, and I will keep you updated!

PS: If you do this yourself you want to make sure that you validate your files on steam after uninstalling runtimes, that way steam can install runtimes needed for the game.

(I don’t know how it works for Microsoft Store, you will probably need to install runtimes manually :thinking:.)


One more thing you should try before going to any trouble of uninstalling any redistributables, check if “Gaming Services” are installed in your Microsoft Store, just got an email regarding my issue telling me that can be the case as well. I had it uninstalled by default for optimization purposes.

For how to install them, you will have to go to this link to install them since I can’t find them manually using Microsoft Store.

1 Like

Found a potential fix that has appears to have resolved my issue completely and allows me to keep v-sync and unlimited fps in game :slight_smile:

I am full AMD with a threadripper 2920 + Gigabyte Aorus Xtreme MB + Sappire Nitro+ 7900xtx = in this combo I was finding a few problems (probably more user problems where I was trying to OC) but turned all the OC off as a baseline. The next step I found was to disable the following settings in my bios (and I played with alot):

  • Core Performance Boost
  • AMD Cool&Quiet Function
  • SVM Mode
  • Global C-state Control

I just played 1hr campaign then another 1hr in multiplayer without a bugspat, or any type of crashing! Is this the fix, not sure, but promising, noting that I use xbox gamepass I am hopeful.

I will note that there are posts and recommendations from AMD themselves suggesting to keep enabled Global C-State and Cool&Quite (as they are power management for the CPU) - so I might try enabling those settings but keep Core Performance Boost and SVM disabled - which I think CPB is maybe the root problem…

Okay, the things I did in my post worked for me. After 4 hours of constant AOE4 gameplay I’m pretty much sure it worked. The only thing I don’t know is if Gaming Services helped or reinstalling redistributables, or maybe even both helped.

Hope I helped someone with similar issues.

Hello, I wanted to post an update regarding our issue here.

While my friends were playing same thing happened to them. We came to the conclusion this was happening because of the 600 pop mod.

It doesn’t happen with any other mod, we tried playing 400 and 1000 pop mod, nothing.

So mine ######### is, while my fix should help you with crashes, pay attention if you crash while using mods.

I’m still not sure if there is a cap for entities (not likely because other mods work fine), or its more likely that the mod is just faulty.

After the fix I have no Bugsplat but now the game freezes at some random time

(I) [20:20:50.728] [000002000]: ENTERING TIMOUT -- Thread info:
(I) [20:20:50.728] [000002000]: - Thread: Main_Thread: running, elapsed run time: 240696.376900ms
(I) [20:20:50.728] [000002000]: - Thread: Simulation_Thread: not running, time since last end time: 240727.290600ms
(I) [20:20:50.728] [000002000]: - Thread: AI_Thread: not running, time since last end time: 240740.047700ms
(I) [20:20:50.728] [000002000]: - Thread: Render_Thread: running, elapsed run time: 240696.524600ms
(I) [20:20:50.728] [000002000]: - Thread: Audio_Thread: running, elapsed run time: 159381.155700ms
(I) [20:20:50.728] [000002000]: - Thread: Loading_Thread: not running, time since last end time: 1722158.425900ms
(I) [20:20:50.728] [000002000]: FREEZE -- The app has detected it is frozen due to 240696 ms elapsing since a frame has been rendered with 0 ms of the process frozen and is crashing itself to report the problem.
(F) [20:20:50.728] [000002000]: [Game] Hang detected. Please check the logs.
(F) [20:20:50.728] [000002000]: -- FATAL EXIT --
 [Game] Hang detected. Please check the logs.```

Hmm, maybe faulty display driver, download DDU from this link.

After you uninstall the driver download NVCleanstall from here.

Check only Display Driver, PhysX and HD audio over hdmi if needed.

After that in installation tweaks you can check this options


Next time it crashes check for more errors and warnings. Latest crash I had was because of a faulty printer software, idk.

How is this not solved yet?

In case you have 2 graphic cards: NVIDIA/Radeon & CPU-integrated graphics.
Try disable the CPU-integrated graphics through BIOS, works for me.

Does anyone have any other suggestions for a potential fix? The game keeps crashing in multiplayer again after the recent server maintanence. Everything was working fine for 2 months (though I did have this issue before) but now I can’t finish a single game if it goes past 30 minutes or so. I have tried pretty much everything that’s in this thread already.