AoE3 DE Multiplayer taking forever to load

:arrow_forward: GAME INFORMATION

  • BUILD #: ######
  • PLATFORM: Microsoft Store
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:question: DESCRIBE THE ISSUE IN DETAIL (below). Limit to ONE issue per thread.

It takes me a very very long time to load into a multiplayer game. This confused me since my computer is relatively fast and I have a wired internet connection and usually hit 800Mbps download. Once I’m in a game I experience no lag at all either. Singleplayer takes no time to load so its definitely not a problem with my computer. I’ve tried numerous fixes, I’ve allowed the game through my firewall (both publically and privatley) and i’ve also tried using a VPN in hopes that they might do something (it did not) I reinstalled the game on another drive (still an SSD) and it seemed to work the first game I joined loaded somewhat fast but after that it took forever to load back in again.

:arrow_forward: FREQUENCY OF ISSUE

:question: How often does the issue occur? CHOSE ONE; DELETE THE REST.

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:question: List the DETAILED STEPS we can take to reproduce the issue… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Load up AoE3 DE
  2. Click on Multiplayer browse game
  3. After everyone readys up the game loads and takes 10+ minutes to load.

:arrow_forward: EXPECTED RESULT

:question: What was supposed to happen if the bug you encountered were not present?

The game would load a lot faster and it would not take 10+ mins to load as it is on an SSD, It doesnt lag when it eventually loads and singleplayer loads very quickly.

:arrow_forward: ACTUAL RESULT

:question: What actually happened (what went wrong) because of the issue you’re reporting?

Its stuck on the loading screen, the animations on the screen dont play/continue and the music stops.

:arrow_forward: GAME FILES

:question: Include a OneDrive or Google Drive link to a SAVE GAME or REPLAY FILE (.aoe2record) of the match where you encountered the issue.

In the loading screen, no replay available.

:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a relevant PICTURE (.jpg, .png, .gif), VIDEO (.mp4, YouTube), DXDIAG FILE (.txt), or CRASH/GAME LOGS (.aoe2record, .txt) below.

In the loading screen, no crashing or any special images other than a frozen loading screen (Game still goes on, I can sometimes hear taunts from other people in the background)

9 Likes

I got the exact same problem too. I wonder if anyone could answer the questions. It certainly wouldn’t cause any problem when I’m trying to play computer as friends. But I literally couldn’t play multiplayer properly with the current issues.

1 Like

Seriously any news on this? I also have this exact bug, i completely re-installed the game and it still doesn’t work in Multiplayer. Just hangs when the game is about to launch until someone cancels it. Also in task manager its clear the game is using way to much memory and navigating even the main menu in game is suddenly a super slow process. .

My friend has this same issue. Every time we play (3v3’s we mostly play) we load in, and everyone but him loads in, we sit for 5 - 10 minutes and then he eventually loads in, but the wait time is maddening.

I played the game like 1 month ago and everything worked fine, then i stopped playing for like 2 weeks and there were a few updates and now my multiplayer games all are stuck on the loading screen after lobby, the game loads instantly but then just freezes for like 10 min, and everybody obviously left allready.
It must be something with a update cause i didn’t change anything to my computer.

Hi,
I also have this issue. It wasn’t present when I first started playing but yeah, about a month or so ago it started happening. I’ve tried reinstalling. Moving installation to another SSD. Verifying game files. Updating graphics drivers. No joy.

Figured out the issue.

Disable/Whitelist your antivirus for AOE3. Specifically in my case it was Malwarebytes.

I was helping my friend with this issue and I didn’t have it myself. Based on the rumors I thought it was a file permission issue so I ran Nirsoft’s Process Activity View on his computer to see what files AOE3 is trying to access. There was a lot of failed options, so I decided to compare that to my own computer trying to load AOE3 (which was known good at the time).

So for the first time I ran into the issue myself and it immediately started loading fast as soon as I stopped Nirsoft from monitor age3de.exe which lead me to believe that the issue was actually Nirsoft inspecting the EXE. Similarly to how an Antivirus would inspect a running exe. So we tested it and disabled Malwarebytes which he has running in realtime mode, and now he loads immediately instead of 5+ minutes. So disable your Antivirus or any other thing that might be monitoring the exe or file system access.

3 Likes

I do have Malwarebytes, but i wouldl ike to keep it active, i can just whitelist the aoe3 map to solve the issue then i gues? I can’t test right now.

I only have Windows Security and continue to have the issue…

Well from this test, I know for sure that there’s an issue when AoE3 loads while another program inspects file usage. The only other thing I can think of that commonly inspects file usage besides an anti-virus might be another game’s anti-cheat software. One of those that run like at the Kernel-level and continue to run even after your close the game.

The popular Genshin Impact game for instance used to do this before public outrage for very legitimate reasons (such as this) to not have the Anti-cheat running 24/7 even when you weren’t playing the game. There could be other games out there that are doing similar things.

Also, I guess you could have some malware on your computer. I remember helping someone with a malware that would run on a computer and inspect what you open so that it would know if you try to open an antivirus so that it would kill it.

Excluding the malware option, you may want to try disabling all non-Microsoft services to see which one could be causing an issue.

Here’s a HP document that you can follow, You only need to do " Preventing all nonessential software and services from loading"

Also of note, If you lose Internet after doing this, you either have a security software you didn’t know about running that stopped running since you disabled it, you potential have malware that you didn’t know about, or you have some really ■■■■■■ wireless drivers (from some legacy component, that requires 3rd party software). So it’s good to know the steps to turn everything back on. Which is to open Msconfig and in the general tab, select normal startup.

If it works, then you know there’s a compatibility issue with another program. If it doesn’t then perhaps there’s another bug unrelated.

If I find something, I usually turn on half of the stuff I had running before to see if there’s an issue, then repeat again until you narrow down the software.

@arnoldstrife, I just want to say thank you, even though your solution didnt work for me I appreciate you taking the time to write out a long helpful answer. The contrast with the Devs absolute silence in the bug forum, the place where people report issues, the things they are suppose to take ownership for, is astounding.

I did turn off all nonessentials but it didnt make a difference

SAME PROBLEM. Can’t even play online. Bought this back in November and have been super disappointed. Figured I’d just stop playing for a few months while they figured out all the bugs but literally none have been fixed. Loading bar gets to the end and then just stops and finally loads 10min later after everyone already resigned. I disabled antivirus, closed every other app, etc.