Barbarossa brawl relic challenge is not completing


the last challenge of Teutons events is to capture a relic in Barbarossa brawl, I have captured purple’s relic and garrisoned it inside my starting monastery then I deleted my TC then I avoided clicking return to map, still after that the challenge is not completing.

what should I do?

1 Like

raising up the thread!

Same problem, I am going for the cyan / Bohemia player instead tho. Put the relic into a monastery, clicked resign - didnt work. Let computer destroy my main TC to end the map while still having the relic garrisoned, didnt work. Tried around with resigning into Leaderboard or returning to map (the statistics show that I captured one relic btw) not working.

Ive had this bug in the Mongolian event too, the game wasnt giving me credit for having a big enough highscore (which I had), tried dozens of times etc. Afraid this is gonna be the same again.

Time gated events and I have to spend more time googling, reading differnt forums and DMing people on reddit asking how they completed the mission than actually playing it. SMH

Same Problem. Tried all ways listed in replies. No luck getting achievement to pop. Gimmie those Onager pretzels Microsoft.

So, what exactly am I supposed to do?

I can get a relic from Bohemia and stuff in into a monastery, its doable after a few tries, sometimes works, sometimes not. After reading on reddit, players claim that resigning after getting the relic will be enough and complete the mission for them. I have tried that, it even says that I did capture a relic in the post-game statistics but the game is not ticking the challenge as completed. Ive done this multiple times and I am starting to get tired of these seasonal events that arent working properly.

I had the same exact problem during the Mongol event, is there any more people with this happening right now?

Could a mod or someone else please shed some light on this? During the Mongols event there was a lot of threads here but literally 0 response from offical side.


capture it and delete your TC – worked for me

thanks for clarifying that - just tried it out, getting relic into monastery and then delete the main TC, game ends, statistics show that I owned 1 relic - mission still unfinished…

Make sure the challenge is unlocked before you attempt it. You have to achieve the challenges in order, and it takes 24 hours to unlock each challenge.

I am aware of that, thanks tho - it was like a week ago that Ive done the previous step. I actually wrote to the aoe2 support and they got back in touch with me, but had further questions, so by the time they respond again the event will be over lol. I mustve played capture the relic like 30 times by now…

I think the solution is that when the victory announcement shows up you have to click “leave map” instead of “return to the map”, or something like that. It’s a problem that has been already attached to the forums.

@Snapdrax The event is already over.