[BUG] Achievement not unlocking

Game Version:

  • Build: 101.101.36906.0 4941835
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: racer 1085


Unfortunately I have a bug with 2 civ achievements in AoE 2 DE. These were successfully obtained on Steam, but didn’t unlock at Xbox Live. I’ve tried to win with those civs a few more times, but Xbox achievements still never unlocked. It’s worth to mention that I was playing offline when they were unlocked on Steam.

These achievements are: Inca Victory and Vietnamese Vicrory. You can see that those were unlocked on Steam on the attached screenshots.

So what can I do now? How can I unlock these 2 achievements for my Xbox account?

Reproduction Steps:

Tried to play skirmish (different modes) and Campaign. All other civs achievements unlock both on Steam and Xbox Live at the same time, but Incas and Vietnamese still do not unlock on XBL.


A post was merged into an existing topic: Achievement problems between steam/xbox accounts: Re-earning achievements