Buged Mongol Event Quest

The Mongol Event bugged out for me.


In Short:
The “get at least 15k Points” Quest never gets checked despite having enough Points.

For a long time my Mongol Event is now bugged. I played the Mongol Scenario on the first date it came out and got already over 35k Points on it back then, but then when i had the Quest to get “at least 15k Points” it didnt worked. I even made the Scenario again after i got the Quest, tried it with finishing the Scenario with good points and even tried with losing on purpose while still getting more then 15k Points and the Quest never worked.
I made the Scenario right now again and the Quest still isnt completed despite me having done its condition several Times.

I waited a bit because it seemed other people had similar issues so i gave the devs some time to fix it, but the Event ends soon, so please fix the issue, so that Other People with the same Problem and I can get our Quest rewards or at least give the Quest rewards to these People manually :smiley:


A post was merged into an existing topic: Mongol Raiders score: 23506. New profile icons: 0