Can not sync up Xbox account with Age 4 on Steam

I am getting an “account linking” unavailable while online.
I am unsure how to fix this since I’ve never seen this before.

Hey @KingMario117! Are you still seeing this? Did you receive any other type of error message?

Was your Xbox account linked previously before the latest update?

I am still seeing this, this is the notification I am getting, and I was able to sync my Microsoft account with my Steam account before.

Thank you @KingMario117! The team will look into it. We very much appreciate the report!

1 Like

Hello! I wanted to bump this post in order to hopefully see if there was any info or work made into finding out whats wrong with my account.

No update yet. There haven’t been a ton of reports with this error, so it’s been a hard one to nail down. You may want to try some of the steps here.

If anyone else sees this happening, please post here or contact support. It’ll be tremendously helpful!

1 Like

Thank you for the support! I’ll try to keep messing with the app to see whats up.

Ive recently tried to redownload/reinstall the game but the prompt to sign into my MC account didnt pop up on Steam.

I also don’t get the prompt to sign into AOE2 DE however my game freezes up when I try to sign out.

That’s interesting you’re having this issue in more than one game. Probably not helpful, but I would try making sure your Windows is updated, as well as making sure your date/time settings are correct.

If you run into a fix through support or other channels, please do update here!

Hey @KingMario117! Any chance you were able to contact support? A warnings.log file could potentially be very helpful if you’re still seeing this. Thanks!

Hello! I can go ahead and set up a ticket with any appropiate information I can gather. I did not end up contacting support.
I can try to update you when I get the chance.

1 Like

I have the same problem and tried several possible solutions, but nothing worked. I was not able to link my account in AoE 4 before but am able to do it on AoE 2 and AoE 3.

@Xyarvius are you seeing the exact same problem where the game shows you as online, but you are unable to link “while offline”?

I also have the same issue

Sorry to hear that @ageekhere! If you could please contact support with your warnings.log file, it would be much appreciated. Thanks!

The error is
XBoxAchievementService::HandleGetRelationships, response error: generic_error
Going to see if the issue is with my network.

Just to be clear, i can play multiplayer games fine though.

Does anyone else get this error in warnings.log ?

I checked my warnings.log and I’m getting the same error. I reported this to support, including warnings.log and dxdiag, but they haven’t been able to help so far.

1 Like

I also have the same problem from the first day the game came out. I always find that it tells me I’m offline, even when the game actually tells me I’m online. Also with AoE2 DE and AoE3 DE I can easily connect to xbox live withour any problem.

@SirGuybrushT please do contact support with your warnings.log file . This is not one we’ve had an easy time repro’ing, so the more data the better. It would be much appreciated—thanks!

I have also been having this problem for a while. I linked my account back when the game first came out, and somewhere along the line it has since given me this message. I have contacted the support team and have followed the steps they provided but to no avail.

still have this problem now months later