Can You Run AOE:DE - A Definitive Checklist

With the official system requirements and an official release date you might be asking yourself

“Can I run AOE:DE on my computer?”

A good question. There are a few key requirements that you will need to be aware of. These are non-negotiable requirements so be very mindful. Saying “Well X is sorta like Y” won’t cut it.

  1. Windows 10

Yes the game requires Windows 10. You are free to hate on Window 10 all you want. You are free to use the subsequent posts to tell me how much Windows 7 is a million times better. That’s fine and all. But AOE:DE requires Windows 10. The game won’t run on Windows 7 no matter how much registry magic you try.

  1. 64-bit

The game requires a 64-bit version of Windows 10. While there probably isn’t a huge contingent of people running 32-bit Windows 10, it is possible (I’ve seen it). Make sure you have a 64-bit version of Windows 10. You can’t ‘upgrade’ to the 64-bit version without totally formatting your computer.

  1. DirectX 11

The DirectX 11 requirement means you MUST have

AMD HD5000 or higher
Nvidia 400 GTX or higher
Intel HD4000 or higher

If your video card is lower than these cards, the game WILL NOT RUN. Period.

  1. But DXDiag says I have DIrectX12! You’re lying to me!

This is ‘technically’ true but ‘practically’ false. The “DirectX Version” you see on the initial page of DXDiag only shows what the OS itself supports. And indeed Window 10 itself supports DX12. But your VIDEO CARD may not.

To check what DirectX versions your video card supports

  • Open DXDiag
  • Ignore the “DirectX Version”
  • Click “Display”
  • In the upper right look for “Feature Levels”

If you don’t see at least 11_1 in the upper right, your video card does not support DX11 and cannot run the game.

  1. But AOE2:HD runs on my PC made from duct tape, bubble gum and Commodore 64 parts! Surely a prequel shoudn’t need a more powerful PC than the sequel!

While I admire your ingenuity for putting together your own Frankenstien-PC, you will still need to meet the minimum requirements set out above.

So keep those hard stop requirements in mind if you’re interested in AOE:DE. I hope this guide will assist you in making the correct determination as to your PC compatibility.

YES! I passed all the checks!

My build crushes the requirements. I hope they put in 144hz support…although, tbh, I don’t think that would make much difference considering the sprite nature of the game.

My macbook pro with bootcamp crushes the competition XD.

Wow! only top line Pcs will be able to run the game! lul

My notebook buy on 2011 pass all check B)
I don’t think is difficult…

Good thing I upgraded my Gateway 2000 machine!

@UnknownMortal said:
Wow! only top line Pcs will be able to run the game! lul

How is any of these specs top?

Right from the Microsoft Store:

Not top specs, it runs on INTEL hd chipset…as for dx11 modern would be a better word…if your pc is 5 years old you may have an issue.

I have an AMD R5, I hope that’s better than the minimum AMD HD5000?

Windows 10, really? They want to sell a game or force a OS, even if a pirated copy?

@Razzee said:
Windows 10, really? They want to sell a game or force a OS, even if a pirated copy?

You had a year to get it for free. Anyone without Windows 10 can’t rationally whinge.

@Fetandrey said:

@UnknownMortal said:
Wow! only top line Pcs will be able to run the game! lul

How is any of these specs top?

Do you know irony?

Yes, should be interesting too considering two separate graphics chips (Intel HD onboard/Nvidia GTX960M).

Are you sure about direct X 11?

https://www.ageofempires.com/buy-now/
This doesn’t say anything about direct X version.

Graphics: Intel HD 4000 or Greater (16 or more Execution Units), AMD or nVidia GPU scoring 500 or more on Passmark G3D Mark

You can score 500 or more in Passmark G3D Mark without having direct_X 11 compatible graphic card.
https://www.videocardbenchmark.net/midlow_range_gpus.html
GeForce 9800M GTX scores 530, but supports only direct X 10.

Are you sure about direct X 11?

https://www.ageofempires.com/buy-now/
This doesn’t say anything about direct X version.

Graphics: Intel HD 4000 or Greater (16 or more Execution Units), AMD or nVidia GPU scoring 500 or more on Passmark G3D Mark

You can score 500 or more in Passmark G3D Mark without having direct_X 11 compatible graphic card.
https://www.videocardbenchmark.net/midlow_range_gpus.html
GeForce 9800M GTX scores 530, but supports only direct X 10.

Are you sure about direct X 11?

https://www.ageofempires.com/buy-now/
This doesn’t say anything about direct X version.

Graphics: Intel HD 4000 or Greater (16 or more Execution Units), AMD or nVidia GPU scoring 500 or more on Passmark G3D Mark

You can score 500 or more in Passmark G3D Mark without having direct_X 11 compatible graphic card.
https://www.videocardbenchmark.net/midlow_range_gpus.html
GeForce 9800M GTX scores 530, but supports only direct X 10.

@UnknownMortal said:

@Fetandrey said:

@UnknownMortal said:
Wow! only top line Pcs will be able to run the game! lul

How is any of these specs top?

Do you know irony?

Yes, and people usually add a smile or /s to show it. At least when it’s not completely obvious.

@Fetandrey said:

@UnknownMortal said:

@Fetandrey said:

@UnknownMortal said:
Wow! only top line Pcs will be able to run the game! lul

How is any of these specs top?

Do you know irony?

Yes, and people usually add a smile or /s to show it. At least when it’s not completely obvious.

u say right… " usually"