Cannot launch aoe2 through steam since console update

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: Cannot see this because I cannot launch

:arrow_forward: ISSUE EXPERIENCED

When I click play in my library the button changes to stop (as if it is launching the game) for 2 seconds and then back to play. No popup or error just back to play. The game never launches. Here is a reddit thread of a bunch of others who have this same problem

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!
It happens every time 100%

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Open steam library
  2. Click play on AOE2

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.


launch the game from the .exe first to see if it gives u any error messages.

if it does, its most likely the vcruntime140 error that I got. have to install latest vc to fix this

where is the .exc located?



wherever your steam is located at

Hmm, that gives me the error “The procedure entry point CreateFile2 could not be located in teh dynamic link library KERNEL32.dll.”

1 Like

ok then im not sure what causes that error. try googling it along with AOE2 in the search as well and see if theres any solution.

thery certainly made a bunch of changes to accommodate the changes they want for xbox, and those changes might not be compatible with older libraries on your system etc.

I have the exact same bug

I have tried verifying game files and a fresh mods/saves/config folder

Edit: Tried installing the latest VC too, didn’t work, the exe gives me the same error as RedPhosphoru

I hope this doesn’t mean they aren’t supporting Windows 7 anymore, I really don’t like Windows 10

1 Like

Hello, having the exactly same issue here. I’ve been able to play the game perfectly in my windows 7 since 2020.
And now suddenly I can’t play anymore. I have been googling and trying different stuff all day long but nothing works.

Hope there is a workaround :,(


1 Like

Take a look at this thread, it might help you :slight_smile:

Yo thanks. They haven’t found the solution tho for w7, but they are trying. Will keep an eye on that thread.


None of that worked sadly

How about downloading that file and placing it in the game folder?

I would consider installing Win10, as Win7 support ended 3 years ago, but this is something that we’re tracking now :slight_smile:

1 Like

Thank you!!
I’ve been trying to upgrade to w10 but my w7 is not genuine, so when I run the media tool it asks for product key which I don’t have. This w7 I have was set up by my father when I was a kid lol and I never changed it nor upgraded it. And I’m quite bad at informatics hehe If you have any tip to share, I would appreciate, but maybe is not on topic here.

You can use win 10 without a license with the only trade off of water mark and reduced features, so you can skip the key part during the installation.

So it’s possible that the game might work again in Windows 7?

I really don’t want to change my whole OS just for this game…


I tried , but the installation wouldn’t allow me to skip the key part :frowning:

1 Like

Hello everyone, im just having the same issue with the error “The procedure entry point CreateFile2 could not be located in teh dynamic link library KERNEL32.dll.” any news about some fix? i was perfectly running aoe2DE in windows 7 since ever until the last update and i really dont want to change the OS (at least on this pc)


Same problem here. Been working fine on Windows 7 till the update now not launching and having the same error.
Hope they get it sorted soon :crossed_fingers:t2: