Cannot Play as DLC Civs but I own the DLCs

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 100,12,39346,0
  • **GAME PLATFORM: Microsoft Store
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.

I own the African DLC and the USA DLC, and both are locked. Have used those factions in the past, this is a new problem.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Start Game
  2. Click Skirmish
  3. Cannot play as desired Civilizations

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

I can play the dlc civs

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.


The same exactly issue. USA works for me, Africans don’t

Hi @Spanderson96, thanks for your report. We are now tracking this issue. Are you signed into the same Microsoft account on the Windows Store & in-game?

Hi @ZorchJr! Are you also using playing on the Windows Store or Game Pass version of the game? (Not Steam).

Yep! Same account.

I’m using the gamepass version if that helps.

1 Like

Hi @Breadalus, first time i installed Games Pass game and Windows store DLC. Yesterday i uninstalled everything and i installed all from Windows store with same result.
I’m using same account as Sanderson96

Ok thanks for letting me know @Spanderson96 & @ZorchJr. Am I understanding correctly that you are both sharing a Microsoft account login?

If the issue is still persisting post-Update 43871,

What could be useful for us is to obtain both of your player IDs from:
C:\Users\<User>\Games\Age of Empires 3 DE
It will be the number on a folder with game data inside of it (Savegame, Users etc.).

and the Age3SessionData.txt file from:
C:\Users\<User>\Games\Age of Empires 3 DE\Logs

If you could each send me a message with that number along with the Gamertag of the account being used we may be able to investigate this issue further.

Thanks! :grin:

Hi @Breadalus ,
today Age has been updated, but the problem is still there.

from C:\Users<User>\Games\Age of Empires 3 DE my ID is 2535405579553205
from Age3SessionData.txt PlayerSessionID = 60f34b61-6a1b-408d-b715-b8d3fd0bac4f

my Gamertag is ZorchJr

Thanks!

1 Like

I have been having the same issue.

My ID is 2533274858932441
PlayerSessionID = 1d3f56b0-0dff-432d-8be6-c9629c8998e1

My gamertag is Mutchellbruh

1 Like

Hi @Breadalus, me too, same issue. I’m in contact with mail support.
I bought both Aoe III DE game, African dlc, and I earned for free US dlc with challenges.
I have access to base game and US dlc. No access to African Dlc.

My player ID is 2533274909420655
Player session ID is ed5fb742-1595-435e-8351-dcfed076ca5b
Gamertag is Naionet

Same problem here. NO DLC since 3 days ago

I also have no access to African civs since the update. @Breadalus

The same problem.
I earned the US dlc
I bought the African dlc (stayed locked)
than I also bought the US dlc
Played a some of the latest challenges
US dlc is now also locked

My player ID is 2533274830836666
PlayerSessionID = 8dcfe5e4-1884-4d79-b726-e028788dd35b
Gamertag is dtdkJohnClark

Please HELP

For me the thing with the powershell worked :slight_smile:

1 Like

Powershell did it :+1:t4::hugs:

1 Like

Thanks! it worked for me too!

1 Like

Absolute legend, fixed it like a charm!

1 Like