Cannot play multiplayer since the recent patch

Hello, I have very long loading times when playing multiplayer games after recent patch. It’s frustrating because once I have finished loading, most of the players have resigned ^^. It takes about 3-5 mins for me to load a multiplayer match. Which is strange, since I did not had this issue before ever. Even the last two beta sessions worked way better than this.

Anyone with a similar issue, or know what to do to fix this?

My PC speccs,
1080 TI
16 GB ram
I7, game is installed on a m2 ssd.

I have tried reinstalling the game + steam.

Video

6 Likes

nah its all the same to me

Definitely not your phatty machine… I’m having the same issues with a similar high-end unit…

I’m having this issue too, in fact I just signed up here to post about it and found your post, since Update 5208, all my online and lan games take 5 mins or more to load, while skirmish loads in less than 10 seconds. it’s not a slow pc issue, I got 70-90 fps on maxed out settings at 1440p during the game, but the loading is making MP unplayable. I have tried everything you can think of.

2 Likes

The issue didn’t resolve its self after a couple days so I emailed AOE support with an extensive account of the issue. I linked this forum post in the email.

The one thing I have in common with the poster is the fact we both have the GTX 1080. Since the issue is very uncommon to AOE 3 DE players, I actually wonder if it’s the software and the GPU not playing nice with each other.

NVidia gave us an update around the same time that we blame the November 5th AOE3 update.

I hope the brass at AOE respond to this post.

2 Likes

Very strange, @JoinedBarley655 , what graphic card do you have, the 1000 series as well? Send me the links and I will try to upload them.

@Krogglestones Would be very weird software bug then, since it is only happening in multiplayer. As it worked fine before. Have you tried to roll back to an earlier update from Nvidia?

I have a 2060, I’ve experienced this issue on both Nvidia driver versions(the most recent one as of now and the one right before) so I don’t think it’s a driver issue. also, my cpu is an amd ryzen 7, my game is also installed on an m.2 ssd. so I tried moving it to the HDD that didn’t help.

Great, thanks for the reply. I have updated the post with links to the videos. Regarding the other loading screen, I have encountered it too.

1 Like

To @H4ste , @JoinedBarley655 , and @Krasitto5951 … I got this response from AOE…


Hello there,

Thank you for all the information provided, I have forwarded it accordingly to our Development Team for further investigation.
We hope to resolve this issue in our future update so please check out our News channel frequently.

Best Regards,
Liya
AoE Support

Are you guys still having the same issue?

why u tag me ? :smiley: my comment above means that its all good for me no issues

oops… i misunderstood then

I still have this issue, can’t play MP at all. kinda sucks even more cuz of the fact that I didn’t play MP on the original, I just couldn’t get into it. but for some reason I enjoy playing the remake. but unfortunately due to this issue can’t play it.

I have the same issue of loading into game. previous patch it took me about 3 seconds, and now it’s more like 3 minutes+.
In single player there’s no problem but quicksearch games however…