Abnormally Long MP Loading times

:arrow_forward: GAME INFORMATION

  • BUILD #: Version 100.12.6159.0
  • PLATFORM: Steam
  • OS: Windows 10 64-bit

:arrow_forward: ISSUE EXPERIENCED

The game takes 5-7 minutes to load into multiplayer or LAN games, even if you fill all slots with bots and no other human players. Skirmish games load fine. thanks to @EaglemutOP we discovered that this issue also occurs in Skirmish if the ‘Record Game’ option is turned on. please check their post below for more information: Click to jump for post with info

This issue didn’t happen to me before [Update 5208]

I added some videos I recorded of the issue links below

And yes I did all the basics: verified game files through steam, reinstalled, windows and drivers are up to date, tried to set all graphics settings to the lowest, restarted computer, disabled antivirus/firewall, tried windowed mode and restarted router. all of this did nothing. and my pc is not a potato, skirmish loads in less than 10 seconds.

Also I can hear the voice commands other players are sending in chat when I’m stuck in the loading screen.

Also it’s worth mentioning some other people have been experiencing this issue as well judging by a thread on the help section and on steam, links:


Please note how both of these posts were posted right after update 5208, it has to be something this patch did.

:arrow_forward: FREQUENCY OF ISSUE

  • 90% of the time / matches I play (sometimes game loads but 1 in 15 chance or something)

:arrow_forward: EXPECTED RESULT

Game should load normally in a short period of time as it was prior to the patch mentioned above.

:arrow_forward: ACTUAL RESULT

Online and LAN games taking abnormally very long to load.

:arrow_forward: IMAGE & ATTACHMENTS

Online and LAN:

Skirmish:

in this video, the slow load one, the loading screen changed but this only happened once usually it’s just stuck on the regular loading screen.

6 Likes

I’ve just started getting this issue today. It takes me about 10 minutes to load into a multiplayer game, even if I am the only human. Singleplayer games load fine. I reinstalled the game from a hdd to a nvme ssd but the issue persists. I played some matches just fine yesterday, and I don’t think there was an update today, so I’m not sure what has happened.

Game version: 100.12.6847.0

Playing through the Xbox application not Steam.

GTX 1060 6gb
32 GB ram
i7-7700k @ 4.5 GHz

Has this issue been resolved? A friend I play with is having the same problem as described above, and as a result we can no longer play.

Starting about two weeks ago, even clicking on the multiplayer menu causes the game to become unresponsive for 10 minutes. After patiently waiting, and entering a game lobby, the game issues a “Failed to Establish Connectivity” error. After this happens, all menus become unresponsive including a task as simple as editing a deck from the home city screen.

It is not related to their internet connection or PC performance, as other more demanding multiplayer titles run just fine on the same machine and interconnect connection. This problem persists after uninstalling and reinstalling the game on the same and new hard drives.

Among the other bugs and glitches posted by the community, this level of poor software coding is unacceptable for a Microsoft sponsored game remaster. Perhaps Microsoft should have focused on more complete beta testing rather than restricting phases to “streamers”, as this new paid beta is apparently a cash grab for fans for the series.

They have also submitted two support tickets that have not yet been responded to. This level of support is not acceptable.

1 Like

This issue is still going on, I haven’t been able to play MP for a month so far, and no one has asked me to provide any detailed information/logs or specs. so they might not be looking into it at all, seeing how it’s effecting a small number of players. sad.

Yeah, same problem here, i have looked at all the threads, nobody of aoe3 team has even answered it. They broke something with an update since it was working fine a month ago for me. I tried numerous things to make it work and nothing helped.

I wonder if it’s causing this problem: Ranked multiplayer games get stuck at "waiting for other players" then say "failed to establish connectivity"

We should all start filing support requests. Maybe that would help. Doesn’t seem like there’s much engagement on the forum.

I have this issue even if no other players are in the game, like if you host a multiplayer game and fill all slots with bots you’d still get the bug. also happens with LAN hosted games. but skirmish loads just fine. so has to be networking related.

Also I’ve contacted support when I first had the issue and I received the “We are gonna inform the dev team about this issue” and someone else who has this issue said the was told the same. but who knows, they could be just saying that to close the ticket as they have no solution. I’ve seen the devs respond to other bugs saying they are investigating the issue but doesn’t seem anyone is bothering with this.

The thing is this bug ruins the game for all people in the lobby not just the person with the issue.

Maybe, the thing is once i enter the game, the game doe start but most people already left by then.
And like someone else said, in normal skirmish it doesn’t happen i load instantly (i have very good pc + internet) but once it is multiplayer even with only bots it happens.

Still no solution here from Microsoft. The recent patch did not rectify this.

The AOE3:DE process consumes 20% CPU and 6.6 GB of RAM at the main menu on my friend’s PC. My working installation consumes only 4 GB of RAM at the menu, while another friend’s process utilizes 2 GB. Can an Age of Empires 3 Game Dev or a rep from Microsoft comment here? The game is unplayable, again after repeated reinstallations after the recent patch.

The next step may be for us to look into the Windows 10 performance monitor to determine if this game has a memory leak, or other defect.

Do you by any chance play on ultrawide resolution? I did, ,and after changing it seems fixed.

I play on 1440p, I also tried 1080 and still had the same issue. the latest patch(9476) hasn’t fixed the issue for me either.

Also, I’m going be reinstalling my OS within a week. I’ll report here once I’ve done that whether this had any effect on the issue.

Couple questions for people experiencing this issue.

  1. If you play a Singleplayer Skirmish match with the Record Game option enabled, do you see similar behavior, or does the game still load fast in Singleplayer that way?
  2. Is your AoE3:DE and/or Windows system installed on a slow non-SSD drive?
2 Likes

I just tested this, interesting:

1- I got the issue in Skirmish if I turned on the Record Game option. so answer is yes.
2- I have the game installed on a Samsung 960 Pro NVME m.2 SSD. I also tried on a regular HDD no effect.

But please note, in MP and LAN games Record Game option is always disabled in the games I tested on.

Good find!

1 Like

Alright, so that confirms my suspicion this is related to initializing a Recorded Game file, which was an issue for some players in the legacy game as well. The root cause/solution is unfortunately not quite so clear.

The thing about DE is, it actually always creates a Recorded Game file for multiplayer games, because it is required for the new spectator mode. Even if you disable the option, a file will still be created; the only difference is that it won’t be preserved and gets overwritten the next time you play a multiplayer match.

Considering the above, DE dev team should really try to get this long-standing issue resolved, because the old workaround of not recording games is not actually possible on DE, therefore the issue affects more people.

2 Likes

This is very helpful, thank you so much for the information. it makes sense now. hopefully that would point the dev team in the right direction.

1 Like

Interesting, could it be related to some Admin privileges or something? That prevents file creation?

Doubtful, I tried running the game and steam as admin, no go.

I don’t think it’s related to privileges, because the file does get created eventually. It just takes a damn long time.

My best guess was that it’s a slow HDD taking too long to do the job, but obviously on an m.2 SSD that doesn’t make sense.

Unless…
@JoinedBarley655 you’ve mentioned having both an SSD and HDD, is your Windows OS actually running on the SSD too? I would assume yes, but if not, that could still be the problem. AoE3 is saving your local data into the Windows user profile folder, which should be on whatever drive your OS is installed on (%USERPROFILE%\Games\Age of Empires 3 DE).

Alternatively, if you’ve got some special setup with the Windows user profile folder being mapped onto a network or cloud of some sort, that could be it.

Both the OS and the game are installed on the same SSD, so I don’t think that’s an issue.

1 Like

As an update from our side, the game and Win 10 OS are installed on the same SSD. This is not related to hard drive speed, as this same computer can play new titles like Cyberpunk 2077 at 60 FPS. The game now freezes for 1 min when hitting enter at the opening cinematic, and consumes excessive amounts of RAM, before reaching an unplayable state where menus cannot be interacted with.

My friend has still not received any reply for the support tickets filed. Is nonexistent support from Microsoft the new norm for their remastered flagship titles?