Cannot unsubscribe from mod

Game Version:

  • Build (32911)
  • Platform (Steam)


Unsubscribing to a mod appears to do nothing, it will be subscribed once you close the game and open it again.

Reproduction Steps:

  1. Unsubscribe to mod.
  2. Exit game.
  3. Open game.

Happen to me as well. Same build/steam. I can subscribe to new mods as well.

Game Version:

  • Build 32911
  • Platform Steam


Cannot subscribe any mod nor unsubscribe them. In the in-game manager, you can change your mod list by (un)subscribe one, while after you restart the game, the mod list is recovered to the previous state.

In the mod management website, click the “(un)subscribe” button can change its text, while after refresh the webpage, it restored to the previous state.

The problem occurs after about 6 p.m. No. 20, 2019 UTC+8 .

Reproduction Steps:

Please see the problem description.

1 Like

I have the same issue. It started occurring before today - I had previously subscribed to the “small trees” mod, but upon starting the game, the local mod folder for the mod got deleted.

If I try subscribing again, the mod seems to work as long as the game is running, but next time I launch the game, the folder containing the mod automatically gets deleted.

This is using the in-game mod subscription menu. If I try subscribing on the website, I automatically get unsubscribed when I start the game.

It seems the bug has been fixed after the 33059 update.

i have the same issue here
steam platform

Game Version:

  • Build 101.101.34223.04509956
  • Steam


“Mods wont get unsubscribed”

Reproduction Steps:

Basically i have noticed that what ever mod you install it stays there for ever. I unsubscribed but it remains.
The error message i get after using the WINTER PACK 2019 is "System attempted to load an incorrectly-formatted asset; some assets will not display".

I didn’t want the mod any more but even after unsubscribing it remains there. The menu is clearly with Christmas lights and the annoying message in the start is there. How do i get rid of this? As i said i already went to mods menu and removed it from there.

Try to remove it from “C:\Users{username}\Games\Age of Empires 2 DE{userId}\mods\mod-status.json” file and from subscribed mods folder.
Main menu is christmas-themed even without the mod, so this is not related.

Thanks for the reply, i checked the .json and the Christmas Mod isnt there. Not sure why im still getting the message for System attempted to load an incorrectly-formatted asset; some assets will not display "

:arrow_forward: GAME INFORMATION

  • Build: June/July
  • Platform: Steam
  • Operating System: Windows 7
  • Gamertag:

:arrow_forward: ISSUE

:question: Describe the problem in detail (below). Please limit to one issue per thread.

Subscribing or unsubscribing to existing mods reset (autodownload or disappear) after rebooting the game, mods I newly subscribe disappear and mods I unsubscribe reappear.

:arrow_forward: REPRODUCTION STEPS

:question: List the steps to reproduce the issue… Be descriptive!

Here’s how to reproduce the issue:

  1. Unsubscribe or subscribe to a mod
  2. Reboot Game
  3. Mods list are as before I changed anything

:arrow_forward: GAME FILES

:question: Include a OneDrive or Google Drive link to a SAVE GAME or REPLAY FILE of the game where you encountered the issue.

:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a SCREENSHOT, VIDEO, DXDIAG .TXT FILE, or CRASH/GAME LOGS (if relevant).

:arrow_forward: GAME INFORMATION

  • Build: 37906
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: Madas

:arrow_forward: ISSUE

I have a weird issue. When I tried to unsubscribe to a mod, it reinstalls when I restart the game. I checked on and it appears that I’m unsubscribed, but still appears as installed. I think that’s why when I start the game all the mods reinstall and it appears on the web and in the game as subscribed. I have tried everything to solved it, but nothing works.

On the other hand, when I tried to subscribe, for example, to the improved grid mod, I’m subscribed until I restart the game. Then, magically, I’m unsubscribed. By the way, the mod never appears on the web as installed.

All the problems started when I change my computer. Before that, all work perfectly fine.

Sorry if I misexplained something. English isn’t my first language.


So, I’m at my wits end here. I have the Steam Version of the game, I had this mod (Mods Single - Age of Empires) everytime I fire the game up, go to the mod tab, its stuck with this infinite loading circle on the left and says its downloading. the descriptions are blank and aside from the “Enable” and “Disable” buttons (which do nothing) I can’t do a thing with this mod. I deleted it and its contents multiple times from my PC but everytime I fire the game up, its like its constantly downloading files into my game nonstop as I cannot get rid of this mod, even after unsubscribing and deleting the files, it keeps adding them back. I also tried to verify the game files on steam and nothing is working.

Also, idk if this is helpful or not, I can indeed download and use other mods, but this one is in a state of limbo. Please someone help.

Here is a picture of my situation:

Can ANYBODY help? Any Community person, employee at Microsoft or Forgotten Empires? the game is having trouble shutting down now too, it takes dozens of minutes to do so and this is the only game on Steam doing it, probably because the mod keeps loading. Can you guys just shut it down or disconnect my game for a hot minute so it cuts the download out or something?

I dont know enough about modding to help you, I’m sorry.

@Juggernaut8704 @BassiAoC @TriRem @PhillySouljah might be able to help

Well, I have to go to work, so hopefully one of them will see this while I’m away for several hours.

Are you logged into xbox live account in main menu? In that case sign into that account on mod webpage and unsubscribe from there.

You can also try to remove mod entry from “C:\Users\{username}\Games\Age of Empires 2 DE\{userId}\mods\mod-status.json” (make backup of that file first), although I am not certain, whether this works.

Thank you, I will try in the morning and let you know how it goes. And yeah In the game, I’m signed on right from the get go. I have tried to unsubscribe from the page the mod is on (the one in parenthesis, I take it?), I’m currently not subscribed when I took that screen shot though

The download size of the mod and the fact that we cannot unsubscribe the mod in-between is the cause of this issue.
I guess you will need to wait till the mod finishes downloading then unsubscribe. It’s annoying that we cannot unsubscribe while a mod is downloading, it’s especially troubling when internet is slow.

1 Like

thank you for answering his question, i didn’t know the answer so i at least tried to grab someone who is knowledgeable about things.

@ Juggernaut8704So would you recommend I just subscribe again and keep the game running until its finished? it seems to keep downloading for quite some time, tbh.