Cant subscribe to Mods

Hello since Today it is not possible to install mods !

u can click “abonoment” but it dont have an effect
we all have this issue and its really pi…us off because some installed it yesterday and it worked
but now we ant play together

Why the ■■■■ cant u just use the dam workshop … at least steam would work

1 Like

Hey there! If you have not already, please try these steps to see if they help them show up in the game:

Let us know if that works for you; if not, we’ll follow up with the team to figure out why they are not appearing.

Thanks for the report!

it is an issue with the server !

We could load it yesterday … but today we can not load anything

it say the " loading mod but then u can still abonoment it and it is not active !

we cant play with our friends at the moment

I have the same issue. I click subscribe on a mod and it says downloading and then a couple seconds later it goes back to subscribe. It says it’s installed on here but nothing downloads and the mod isn’t available.

Tried on multiple mods and I have opened the XBOX Console Companion and signed in as well but it still won’t download.

1 Like

I have the same problem. I click “Subscribe”, the button turns to “Downloading” but then goes back to “Subscribe” without any information or error message. Really weird.


I have the same issue, spammed subscribe button for about 5-10 minutes and tried using the companion app as outlined in the help link. Still having the issue.

We try to copy the files in the mods folder but that also don’t work :frowning:

1 Like

Where do you find the files? I would also like to try manually installing the mods…

if u have installed a mod go to the insalled mods page in game
on the right side u find open folder

Normal is C:\Users\username\Games\Age of Empires 2 DE\Long ID Like 1454545444444\mods
There u will find a folder subscribed in that one are the mods

Reinstalling the game did it for me

Hi guys,

If you download a mod from the game itself, it will save in users > games > aoe2de etc.

For something like a taunt pack I believe you have to copy the mod from this location and replace the original bnk file in the actual program files location

I had the same problem lately. For anyone looking for a solution, here is what fixed it for me:

  1. Open Xbox Live Settings
  2. Verify the connection status
  3. Make sure you fix any problem by clicking the “Fix It” button
  4. Press “Check Again” to check if problem was fixed

After that my mods were installed perfectly.