Can't upload my custom campaign

Hi there.
I recently made an update about one of my custom campaigns, but for reasons unknown I can’t upload it. Oddly enough, a previous update about the same campaign and a couple of updates for another were uploaded. Both the campaigns are in the local mods folder. I simply can’t find the campaign my the “My Mods” tab.
How can I fix this?

1 Like

How are you uploading them? Do you use the official website, package it as a zip, and upload it from the mods page on the website?

From the mod tab in game. Ever since the last update I can’t upload the updates of the campaigns.

That’s always been really buggy, here is my advice that works well for me. Go to your mod on the page (The link is to your mod): Mods Single - Age of Empires, and sign in. Then, open your local mod directory, and find you campaign. Go down one file from the mod name, so you have the files “resources” and “widget ui” etc visible. Then, select all of those, and turn them into a zip, I recommend using 7zip. Now, go back to the browser, click edit, and upload your zip. Hopefully that works and makes sense.

Hi @Jimakus21 @TheConqueror753 !

Could you provide more information? Why uploading mods or campaings is buggy ingame? Do you have a video?


I don’t have a video, but I have a screenshot. My Viking Invasion of England campaign is on the local mods folder in my pc. I tried to fix some bugs and wanted to upload the update, but that is impossible.

You can upload it via website but not ingame then?

Doesn’t work. Nothing happens.

I can’t upload it either way.

I see. Why cannot you upload it via website? Do you have a video? Does it happens the same as ingame?

Almost same thing. It is as if the zip file doesn’t exist.

Oh you are trying to upload it as a Zip? Maybe you can try to upload it as a regular folder?

We have created a ticket with this information and we are tracking it internally! :smiley:

First, I tried to upload the update as a regular folder. Then, since I couldn’t I tried as a Zip.

Cannot upload mod,too,please the officials check!

I found and fixed a bug related to publishing. Please try again and hopefully you should have better success.

Well the mods I attempted to publish/delete yesterday are reflected now, but publishing/deleting mods still doesn’t work.

What happens when you try? I was able to publish one just now with no problem and I’m not seeing any errors in the logs. Also are you trying from the web site or in the game?

I try to click the submit button,it circles a round for 10s, after that time it stopped circling round and failed.In addition when I make the comments or rate for another mod,the rate and my comments cannot work,please check my account please,thank you once again.

+1 as the same state above, please check the account, thank you.