Challenge Reward Deleted AGAIN!

### Game Version: 101.101.36202.0

*** Build: ?? 4819260 ??**

*** Platform: Steam**

*** Operating System: Windows 10**

*** Gamertag: DerEider**

### Issue: You are doing it again ! The day after I completed the 3 Arbalester Challenge, You removed the check mark and are making me complete the Challenge a second { & maybe a third or more ?} time !! WHY ?? How many times must it be completed ? If more than once, You should so state in the Challenge !

You did the same thing to me { & how many others ?} several times in the Spring Challenges. You never replied to my BUG report submitted at that time.

How many times must a given Challenge requirement be satisfied before it is shown as being completed ??

A particular concern is that a Challenge completed near the end of this Challenge period will not be recognized as complete and the corresponding reward will not be given.

### Reproduction Steps:

1) Launch game.

2) Note the current Spring Challenge.

3) Play the game, taking care to complete the current Challenge criteria. I.E., Train at least 3 Arbalesters in a single game. Finish game. Exit and receive Challenge reward pop-up.

4) Next day launch game & note the Spring Challenge status showing the previously completed & “congratulated” challenge as still NOT completed.

Here’s how to reproduce the problem: As detailed above.

1. (List the steps we can take to reproduce the bug ourselves…)

2. …



Congratulatory pop-up on 30APR2020:

Challenge status page after training 3 Arbalesters on 30APR2020

Challenge status page 4 Days after completing the Challenge:




As an addendum, the following Challenges are not unlocking.
Does that mean I may not unlock following Challenges until the preceding Challenges have been completed ?

I can only do one challenge each day and in the order of the list.

Well, congratulations Devs … You’ve succeeded in a repeat performance !!
You once again have deleted my completion of the “Train 3 Arbalests” event.

I completed “Train 3 Arbalests” event yesterday and, by early AM today, you canceled it AGAIN !!
Not only that, you STILL will not UNLOCK “Research Chain Mail”, which I just did in my last game, nor any other subsequent event.
strong textEVIDENCE:strong text

  1. OK, now I’ve completed “Train 3 Arbalesters” challenge 2ND time & it’s checked off … HOW LONG will this last ?? … Screenshot dated 05MAY2020 at 2217 CDT {US} - LINK:

  2. AGAIN !!! Xbox/Microsoft has removed the completion Check-off for “Train 3 Arbalesters” … Screenshot dated 06MAY2020 at 01410 CDT {US} - LINK:

OK, why not give me a little break and let me do some of these Challenges ?
HOW MANY times must I do each event ??

And if you mess around with the level editor enough all your supposedly permanent rewards will be gone as well.

What’s a “level editor”?
I don’t want to accidentally do that !

Sorry, scenario editor.

I reported this in the scenario editor improvement thread as well: I went messing about with ludikris sized maps with lots of water and elevation. It slowed down the editing tremendously, okay, fine so far, but eventually apparently messed up my game files, making me lag and stutter in online play. I wasn’t using the map I edited mind you. I reconfirmed this later after fixing it, I tried editing the map and the same problems reappeared. The first time verifying the game files fixed it, the second time I had to go in for a fresh install. I don’t remember when exactly the aoe1 event unlocks I had were gone (I had them turned off at the time), whether it was before or after my fix, but since the fix had to be done I don’t really think it matters. (Unless these are unrelated and the game just randomly deleted the unlocks, then it kind of matters, but I have no way of distinguishing that option.)

So… don’t scenario edit ludikris maps with lots of water and any elevation.

Game Version:

  • Build: 101.101.36906.0 4941835
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: Spread The Pain


Issue is: Challenges from the current event (Greatest Medieval Technologies) are not being saved upon exit.

  1. The challenge is reset every time I got it as soon as I exit. Times show that as soon as I get it, it stays there as long as the game is open, but gets erased as soon as I shut down game. I am signed in to XBOX in case you were wondering.
  2. Got the screenshot since this is the 3rd time I’ve got this challenge, but it still will not register.
  3. Have pressed windows button to take a screenshot with the time.
  4. I have also tried logging out of XBOX and signing in and then doing the challenge, but it still persists.
  5. The odd thing is, I was able to advance after finishing the first two challenges, but this one simply does not register with the server.

Reproduction Steps:

Here’s how to reproduce the problem:

Steps: 1. Finish the challenge that is required from the current event.
2. Exit game.
3. Restart game.
(Pretty straight forward.)


:heavy_check_mark:2 Screenshots attached with time

1 Like

Same for me, except AoE2-DE Devs won’t unlock “Chain Mail” for me.

What happened on 05-06MAY { also happened on 30APR-01MAY}:

  1. OK, now I’ve completed “Train 3 Arbalesters” challenge 2ND time & it’s checked off … HOW LONG will this last ?? … Screenshot dated 05MAY2020 at 2217 CDT {US} - Screenshot LINK:

  2. AGAIN !!! Xbox/Microsoft has removed the completion Check-off for “Train 3 Arbalesters” … Screenshot dated 06MAY2020 at 01410 CDT {US} - Screenshot LINK:

The funny thing is, the Spring event went quite smoothly. This means they had to make an effort into changing the code/logic to create a bug probably.

Hello everyone! For those of you experiencing this issue, we could use a copy of your network log to help dig into the issue. If you are still having trouble, please PM me so I can provide steps on how to collect this information.

Thank you all for the report!

1 Like

@GMEvangelos [developer], I am unable to Paste the AoE2-DE Log for my THIRD completion of the “Train 3 Arbalesters” challenge …
I tried pasting into a word doc, but it ran over 1700 pages and froze the document.

I also see the Log for my 30APR2020 completion of this challenge.

HOW may I convey these Logs to you ?

EDIT: I have saved the Log into a desktop Folder.

Please upload these logs to a Google Drive or OneDrive folder and share the link here or in a private message. I will pass these to the Test team so they can investigate the issue further.

Game Version: …

  • Build: 36906.0 0
  • Platform: Microsoft Store
  • Operating System: Windows 10
  • Gamertag: Wenzelmeier


Progress got reset. I did the the first and second task yesterday. After that i had a timer for ~8 hours. Did the next mission today after timer should have ended. Nothing happened. Logged in again later, the second task got reset. Did it again. Got the notification. And now i have a timer for ~17 hours.
If that keeps happening im afraid i wont be able to do all the tasks wich would make me very sad.

I am starting age through the Xbox app, so i should have been logged in to Xbox Live.

Reproduction Steps:

Here’s how to reproduce the problem:

  1. Do task 2 ( “Train three Arbalesters in a single game.”)
  2. Wait timer
  3. See that mission is reset


No earlier screenshot since i didnt expect this happening. This one is from today, if it keeps happening

I have placed the Log files in a OneDrive and attempted to “share” to the following address:
This gives a “No result” and does not appear to complete the “share”.

I am not familiar with the use of OneDrive. Can you advise on how to proceed ?

Pack files into zip, upload here (use link transfer option instead of email) and post link here.

OK ? I executed a Link transfer via “WeTransfer”, but I could not verify WHERE it went. WeTransfer says it was successful & will hold the file for 1 week.
Content was 7zip of “logs_AoE2-DE_MTchallenge-Debug”
Code they gave me is:

So apparently after doing it a second time, progress was saved and i could do Task 3…wich also got reset. So 2 for 2 i had to do the tasks twice… Is that intended this way???

I am having the same issue when I play with someone else it says I get the unlock but then the next time I load the game it does not actually unlock. only way I have found around this is to do all of them in single player and just cheese them via settings for the games and on easy vs one ai

Same issue, stuff won’t unlock, and already unlocked stuff locks again.
Please fix and never lock non-profile images behind timed events ever agian.