Chasing the crown achivement not working

Yep, that hurt me a lot :frowning:

1 Like

Just downloaded an update, so thought I’d give it another try. No luck.

Current version 101.101.43210.0 0

2 Likes

I have the same problem as of 11/28/2020. It took me a few times and I am sad it didn’t work. Hopefully it can get fixed.

3 Likes

Haveing the same issue over here! deff A game problem! :frowning:

2 Likes

Same issue here. I killed the guy twice in less than 5 minutes. The secondary objective mark got ticked and later it told me that I killed him, despite the fact that he has already been dead for a few minutes.

4 Likes

:arrow_forward: GAME INFORMATION

  • BUILD #: 4#####
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:question: Chasing the Crown Archivement doesn’t works, i have done it in less than 5 minutes even complete the scenario in less than 5 minutes and dont works

:arrow_forward: FREQUENCY OF ISSUE

:question: How often does the issue occur? CHOSE ONE; DELETE THE REST.

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:question: List the DETAILED STEPS we can take to reproduce the issue… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Start the scenario
  2. Kill the king in 2 minutes with the arambai
  3. Capture the monument and complete the scenario in less than 5 minutes/after 5 minutes/ in every difficulty/ally portuguese/dont ally portuguese, every combination

:arrow_forward: GAME FILES

:question: Include a OneDrive or Google Drive link to a SAVE GAME or REPLAY FILE (.aoe2record) of the match where you encountered the issue.

:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a relevant PICTURE (.jpg, .png, .gif), VIDEO (.mp4, YouTube), DXDIAG FILE (.txt), or CRASH/GAME LOGS (.aoe2record, .txt) below.

Thank you all for the report! The team is aware and investigating this issue! I’ll let you know if there is anything else you can provide that will help them in their testing! :+1:

8 Likes

So, it will be fixed soon?

1 Like

I have the same problem, hope it gets fixed soon, I want to complete all the current achievements before the expansion adds more!

2 Likes

Hopefully gets fixed before the expansion. I’m trying to complete all and I’m just lacking this one and the 1v3 in mp game. The good think it’s that this is an easy one.

2 Likes

Has there been any progress on this? Still not working for me.

I’d like to point out that there is at least one other broken achievement. “Eternal Gratitude” for finding a penguin in the Historical Battle “Vinlandsaga”, which has apparently been unobtainable for a few months now. There is currently a thread for that here in the forums. It would be greatly appreciated if the dev team could diverge some attention to that as well, so people can get the 100% again. Thanks for your time.

1 Like

We are already in 2021 and the issue isn’t solved. As I try to do it today in different ways and doesnt work as well. Please, we still waiting for this resolution, do not forget about it!!!

1 Like

Yep, this issue comes from the anniversary patch and the devs don’t do anything to fix, it’s damn disgusting.

Guys, chill, I know it’s annoying, but devs like to release bigger patches monthly, we’ll have to wait till the next one, they won’t just release a patch to fix this one issue

1 Like

Yes, it still doesn’t work. Tried to earn a few others in the mean time like the sheep one for example and it didn’t work. Got 24 sheeps and didnt get the achievement. It’s annoying that it hasn’t been fixed, but at the same time it isn’t gamebreaking so i understand why devs might be focusing more on the DLC and other things. Still if this issue continues with the expantions, then I’d say we have a valid point to complain.

AS well , Same for me . “Eternal Gratitude” & " Chasing the Crown" didn’t work .

1 Like

Both issues are logged! When a fix is implemented, watch for the note in an ‘Achievements’ section of the update notes! =)

5 Likes

still not working…

The Dev said they’re logged, not implemented yet. I’m sure it will be part of the expansion update.

2 Likes